Does FMOD 1.06.09 support UE4.9?

Please ignore this post if it is known that latest FMOD version has not yet been updated to support UE4.9!

My actual question is in the title. What follows is some background.

On the FMOD plugin download page it only says UE4.8, but since v1.06.09 came out a day after UE4.9 was released I though it was assumed to be working.

After converting my UE project from 4.8.3 to 4.9 I can no longer hear any of my FMOD sounds in PIE or standalone. My sounds still play if I open to “edit” my sound assets and hit the Play button.

I did rebuild the banks and GUIDs with latest FMOD studio.

I also tried using FMOD in a blank test project without success.

In case it might prove useful, I tried tracing where the problem is by debugging in Visual Studio. I got to this line in FFMODStudioModule.cpp. The resulting &EventDesc is null even though the supplied &GUID is correct.

As mentioned here

You should be able to compile the current project and have it work for 4.9. If you are debugging into FMODStudio code then you’ve got that far. It sounds like the plugin is actually playing sound as well, but something has gone wrong with the existing links the assets.

Can you contact and send a log file, so I can see if there are any errors that it prints out?

Just to follow up on this, I resolved my issue, which seems to have been my fault. I can confirm that FMOD 1.06.09 does work for code projects in UE4.9. My particular problem was that I forgot to update the Oculus Audio SDK files in my FMOD project’s Plugins folder. On the other hand the ovrfmodXX.dll files in my UE4 Plugins folder were updated to the latest version when I updated the UE4 FMOD plugin which comes with the latest ovrfmod files.