FMOD Plugin Error - Unreal Editor 4.11.0

UE 4.11.0 can’t read FMODStudio plugin.
Noticing messages below.

Message 1 - Plugin missing or incompatible
Missing or incompatible modules in FMODStudio plugin - would you like to disable it? You will no longer be able to open any assets created using it.
Message 2 -
Plugin ‘FMODStudio’ failed to load because module ‘FMODStudioOculus’ does not appear to be compatible with the current version of the engine. The plugin may need to be recompiled.

The plugin can only be compiled against one version of the engine at once, but it already works with 4.11 and can be rebuilt easily. I just tested our last public release against a fresh version of 4.11 and it works fine.

Please see point 2 of this post:

The same instructions are also mentioned at the bottom of this page:

We’ll rebuild for 4.11, although we may have a patch release coming in the next few days and we do one last 4.10 release first, since there are some important fixes that are waiting release. That means it may be another few weeks for the versions to appear for 4.11, so you are better off following the above instructions to get it early.

Thank you very much for your answer.
I could solve this problem with your answer and some try.
Compling need ‘deleting some files’, ‘create a new C++ project’, and ‘restart that project with plugin folder’. I got it.

This below is I’ve read to solve this problem.

Compiling the plugin (Optional)

If you want to recompile the plugin, you can drop the plugin into a code project under your game’s Plugins/FMODStudio directory, then re-generate the project. This might be useful if you want to use the plugin with a different version of the engine, such as a new pre-release of UE4. You can also do this if you want to get the plugin from github.

To recompile the plugin after downloading it from FMOD, do the following:
•Delete the FMODStudio/Intermediate directory.
•Delete the FMODStudio/Binaries/Platform/UE4*.* files. Leave the fmod libraries in the binaries directory!
•Create a new code project using UE4.
•Copy the plugin into YourGame/Plugins/FMODStudio.
•Regenerate the game’s solution or xcode project.
•Build the game for “Development Editor”.
•Build the game for whatever other configurations you need.

To compile the plugin after downloading the source from github, do the following
•Add FMOD dynamic libraries into the FMODStudio/Binaries/Platform/ directory. The libs can be obtained in the Programmers API download or from the UE4 integration download.
•Create a new code project using UE4.
•Copy the plugin into YourGame/Plugins/FMODStudio.
•Regenerate the game’s solution or xcode project.
•Build the game for “Development Editor”.
•Build the game for whatever other configurations you need.

1 Like

Hi, my experience with Visual Studio (e.g. for creating a new code project, regenerating the game’s solution, building the game for ‘Dev Editor’, etc.) is extremely low.

Can someone please link to a YouTube tutorial that shows how to recompile or suggest another way to get a later version of UE4 to work with the FMODStudio plugin? For instance, can I simply delete the last version of UE4 that had the FMODStudio plugin in it if only can be compiled against one version of the engine at once?

You don’t have to do something with Visual Studio, just install Visual studio including Common tools for Visual C++.
And, 1) make a UE4 project - not a blueprint project but a “C++” one.
2) Close the project.
3) make a folder named ‘Plugins’ in the project folder.
4) Copy FMOD integration’s ‘FMODStudio’ folder into ‘Plugins’ folder.
5) Delete ‘Plugins/FMODStudio/Intermediate/’ folder.
6) Delete ‘Plugins/FMODStudio/Binaries/[Platform]/UE4*.*’ files. - [Platform] means ‘Android, IOS, Mac, Win32 and Win64’
7) Launch Unreal Editor and open the project.
8) Unreal editor ask you a question box, you should answer ‘Yes’. - Unreal Editor will recompile plugin data.

1 Like

Great! I encountered some UE compiling error messages twice along the way but opened the project up in VS, built it, and now have FMOD/UE4 integration again for the test code project. Thank you.

I’m now trying to recompile the FMODStudio folder into the UE4.11.0 engine folder such that all my projects will have FMOD support; however I am running into this error message: Plugin ‘FMODStudio’ failed to load because module ‘FMODStudioOculus’ could not be found.

I believe I have this module because I ran into a similar problem integrating an earlier version of UE with 1.08, which led me to download a file called FMODStudio.uplugin off Github (this fixed it with the earlier version, not the current one.)

Any thoughts?

The message about Oculus is most likely the version mismatch. You’ll need to make sure you rebuild the plugin following the above instructions for 4.11.

We’re preparing a new release right now that will have 4.11, so if you want a few days then you’ll be able to grab our latest release and just use that instead.

1 Like