Error with Programmer Sound and Asset Bundles

Hello! We are doing a mobile port of a game from several years ago with FMOD version 1.10.

Currently we cannot update the version because it causes us a lot of errors in the project and we want to do this as a last resort since it would consume us a lot of time. If by chance you confirm that it is a version problem, then we will start with the update. But without knowing for sure we can’t put that much effort into it. The Unity version we are using for the port is 2021.3.12.

I will detail the problem. We have configured the sound banks by asset bundles and for now the loading and playback of events does it without problem.

The problem is with the programmer sounds. When we use them we get this error:
[FMOD] CodecFSB5::canPointInternal : Cannot FMOD_OPENMEMORY_POINT non-PCM data.
Programmer sound: Can’t create sound, key IntroBrotherhood_0 ERR:ERR_MEMORY_CANTPOINT

If we use banks such as StreamingAssets there is no problem, it is only when selecting the AssetBundles option.

I was able to get it running locally, using AssetBundles and FMOD 1.10.20, are you able to provide more information:

  • Exact FMOD Version.
  • Platform/s tested.
  • How are you loading the AssetBundles?

Where can I see the exact version of the FMOD plugin installed?

In the menu bar, ‘FMOD > About Integration’.

Hello Cameron, here is all the info:
FMOD Plugin: 1.10.13
Platform: Android

Now I have more info. When I build the banks with Encoding Format FADPCM or Vorbis, I have this error. But when I build the banks with PCM format, works perfect.
The problem is that format is a very big size bank and I can’t use in Asset Bundles for the AAB.

Thanks for that info.

You may want to check your programmer sound creation code, in particular the FMOD.MODE.

This is from Studio::System::getSoundInfo

“When the banks have been loaded via Studio::System::loadBankMemory, the mode will be returned as FMOD_OPENMEMORY_POINT. This won’t work with the default FMOD_CREATESAMPLE mode. For memory banks, you should add in the FMOD_CREATECOMPRESSEDSAMPLE or FMOD_CREATESTREAM flag, or remove FMOD_OPENMEMORY_POINT and add FMOD_OPENMEMORY to decompress the sample into a new allocation.”

Perfect, with this works.
Thank you!