Failed to rename asset error

I’m diving back into an older project, and suddenly getting “Failed to rename asset” errors whenever I try to organize or make any changes to assets in the Asset List.

What usually happens is I get that error, a show details button, and then a block of blank text where the details should be.

If I look in the finder, I will see a new folder with the name I attempted to rename the old folder to, and it will be empty.

This project is stored on Google Drive; is there something going on with that? I tried copying locally and changing permissions via finder but still great the error.

This error usually indicates that the file has been set to read-only. If you mark the files in your asset directory as writable, FMOD Studio should be able to rename them without difficulty.

Incidentally, some forms of source control automatically mark files as read-only. If your assets were stored in a Perforce repository or similar source control repository at some point in the past, that might explain why they’re marked as read-only now.

1 Like

Thanks for the response. I’ll check with my developer on that. We do use Perforce, but I don’t believe the FMOD project was ever uploaded to our repository.

I’ve changed Permissions in OSX to “read and write” for everyone, and applied to all subfolders, but I still get the errors in FMOD when I open the project file. That’s my main concern, since I don’t actually know what the problem is or how it occurred.

What are the errors you get when opening the project? They weren’t described in your original question.

The errors cropped up when I was trying to re-organize the asset folder. If I rename a folder there, a popup would say “Error renaming file” and list all the files in the folder; and then cleaning that, a second popup would occur saying “There was an error creating the folder X.” The details pane is oddly empty.

Hmm. If all the files and folders are writable, the cause must be something different. Are you able to send a copy of your project to, so that we can examine it firsthand? I haven’t managed to reproduce the issue here without it.