Project doesn't open anymore and i did nothing diferent! failed message

“Failed to clean up .unsaved directory in project required for migration. Please verify you have write acess to project directory.”

My FMOD crashed in a project and now it doesn’t open anymore, just keep showing the message above. I just tried to delete some assets from the project, FMOD didn’t deleted them, crashed, now doesn’t open anymore. i didn’t update it either, i’m using the same version since the beginning of this project. FMOD 2.0.8

Please heeeeeelp!

It sounds like your project files have been corrupted somehow. Unfortunately, without access to your project, there is no way for us to identify the exact nature of the corruption, but it sounds like some or all of the files in your project may have been set to “read only,” preventing FMOD Studio from writing to or deleting those files. This is most commonly a side effect of synchronising your FMOD Studio project folder to a third-party file upload service such as Dropbox, or of using source control without using an FMOD Studio source control integration. Have you tried accessing the properties of all files in your project, and toggling off their “read only” property?

When you say you tried to delete some assets, how did you try to do it? Did you delete the files in FMOD Studio’s assets browser, or in an Explorer or Finder window?

1 Like

Hello Joseph thanks for you help! I solved the problem
None of the files were “read only”.
I tried to remove the old assets using FMOD assets tab(right click-delet).
I solved the problem reinstalling FMOD.
I think you’re right! the problem was resulted by a sync with the cloud project.
Reinstalling FMOD solved it!

This solution did not work, and I am just spinning wheels with none of my files opening after I close the program.
I am confused by this error and wasting valuable time losing work.
I have uninstalled and reinstalled this studio app, and deleted files manually and through the application. Zero effect.

Unfortunately, without more information, there is no way for us to identify the exact nature of the problem. Are you able to send us a copy of your project?

Are you able to give us more information about the the problem you’re having and its symptoms? Which version of FMOD Studio are you using? If your project located on a network drive, or in a folder subject to source control or cloud synchronization? Which files did you delete? What do you mean by “deleting them through the application” if FMOD Studio won’t open your project?

I would love to get an answer, and I will get any info I can which helps. I did not mean to sound impatient, I am just frustrated.

I got into this too because of a sound designer I know suggest this tool. He helped me a little during the installing process, but I kinda of pieced the process together on my own, which means I could have easily screwed up.
I am trying to use FMOD Studio version: 2.02.04 for my Unity project
My project is located on my C:\ drive, where one was initially tied to GitHub, which did not work, and then another project located inside my project folder, away from Github, but still on the C:\ drive.

I saw in a post elsewhere that someone was able to go through the asset import window and delete files that the error says have not been cleaned up. I can open a new session in FMOD Studio, and use File/Open to locate my project folders, navigate to the folder the errors mentions and tried to delete the questionable files. Then navigated to the project file to try and open it. Corrupted.

All the folders which hold any FMOD project are set to “Write”, and no other app I use has any issues.
I have been able to build tracks and get them into Unity fine, but when I open the FMOD Studio project up again, it tells me it’s corrupted, using this same error and I have to rebuild it again.

Then uninstalled the Studio app, re-installed it, and created a new project inside the Documents/FMOD Project folder/NewProject. Saved it, closed the app. Tried to open it again, got the same error.
So I am unsure which direction to go.

and now I can not even open the example files.
I clearly installed this incorrectly, somewhere somehow.

Unfortunately, I haven’t been able to reproduce this issue using version 2.02.04 of FMOD Studio, which makes me suspect there must be some difference between my test machine and yours.

When you try to open your projects, how do you do it? Do you double-click on the .fspro file in Explorer or Finder? Or do you open FMOD Studio, then select “File > Open…”?

Have you checked your hard drive for errors?

Do you have any kind of whole-drive synchronization service (such as OneDrive) enabled?

This is very strange. As you say, this probably means there is something wrong with your installation of FMOD Studio.

Could you describe in detail how you installed FMOD Studio? Did you run an installer downloaded from https://www.fmod.com/download, or use some other method?

Did you install multiple different versions of FMOD Studio? Did you install FMOD Studio in the default location?

I started wtih the idea it was just a component added in Unity, and started with this step. I fear this may have created a breach in the normal set up.
It wasn’t until later that I was aware it was a total different app with an API into Unity.

Should i uninstall the FMOD set up entirely (from project and system) and start this over?

If so, I think I am in a spot where this could be a challenge in finishing my product, but also a perfect time to try this. The work I have in my project is easy to rebuild, mostly. Again, if so, I will take the proper steps to get this to work correctly.

Changing the order of installation shouldn’t cause this kind of issue. The FMOD Unity integration loads bank files built in FMOD Studio, and can be connected to FMOD Studio via live update, but does not make changes to your FMOD Studio project. As such, it is not able to change your project in ways that prevent it from being loaded in FMOD Studio.

That being said… Unity automatically creates .xml files corresponding to every file in its assets directory. This means that if you place your entire FMOD Studio project in the Unity project’s assets directory, the additional files automatically created by Unity will interfere with FMOD Studio’s ability to load the project. If you have done this, it might explain the issues you have been having.

To clarify, if you create and save a new FMOD Studio project in FMOD Studio and do not link it to a Unity project, can you close the project and re-load it in FMOD Studio?

yes i can open a project not associated with Unity

In that case, something about the way you’re associated your FMOD Studio projects with Unity projects must be causing the problem.

Can you please describe in detail how you associate an FMOD Studio project with a Unity project, and where you are keeping the FMOD Studio project relative to the Unity project.

I am not entirely too sure exactly how I installed the Unity component, but I would think I went to the store to locate the package, and then added to my list of items in the store queue.
Inside Unity, I downloaded it onto my project.
Here is where I definitely was a little confused:
First, I was using Github, which I have learned is not very well supported with your tools at this point.
My programmer told me to install the FMOD studio folder inside of Unity Project, but outside of the Assets folder, which i did.
Once I installed the component, before I understood there was the FMOD Studio app, I was trying to get the tool to activated. I went through the process of removing any of the Unity Audio Listeners and converting Unity to use FMOD as the audio controller.

After that I was just clicking buttons over and over until I got the FMOD Studio installed. Once I did that, I was able to open files.

My audio guy sent me a simple bank which I added into the Unity project ok, but have not been able to open it up in Studio ever.

When I open up a working file set, I would create a build of banks and let it sit inside the directories FMOD created be default. I would then save and close FMOD Studio.
I see the studio file, but the error persists.

from this point on, I have been creating folders inside of some dummy Unity projects, outside of them, and anywhere else I could. Keep getting the same error.

Most methods of source control automatically mark files as read-only or open files for reading or writing. This prevents FMOD Studio from accessing those files correctly, unless one of FMOD Studio’s source control integrations is used.

Your programmer is correct. As I mentioned above, placing your FMOD Studio project in the Unity project’s assets folder will cause Unity to add additional files to the project that interfere with the project’s normal function.

This is expected and normal. Banks aren’t designed to be opened; they’re a “built” format that is not editable or human-readable, so as to prevent your game’s players from opening up your banks, copying your assets, and making changes to your game’s sound design.

If you want to make changes to a bank, you must instead open the FMOD Studio project that was used to create that bank, edit the project, and then build a new copy of the bank.

What error message appears when you try to open your FMOD Studio project in FMOD Studio? I’ve been assuming it was the same “Failed to clean up .unsaved directory in project required for migration. Please verify you have write access to project directory” reported by the first post of this thread, but some of your most recent post makes me think you may be experiencing some other error.

I get that error, and now it comes with a file I did not make a build on. Should I remove the FMOD out of my current residing in Github, and install the apps and components all over, outside of any source control?

As I mentioned above, most forms of source control that don’t use an FMOD integration will cause problems for FMOD Studio projects, so it’s entirely possible that GitHub is responsible for the errors you’ve been experiencing. I can’t be sure without examining your machine first hand, of course, but as this is a plausible explanation for the problems you’ve been having, I recommend trying it.