Error processing (An operating system based file error was encountered.)

Hi.

We are having a major error with FMOD after setting up the Source Control between a previously existent Mac project and a new Windows workspace.
I am using 1.10.14 with Perforce as Source Control.
After setting up the windows project we found that we had some character encoding issues and we solved them in the mac version. I pushed that changes to Perforce and Sync in the WIndows.
It was weird because the Windows Project didn’t understand that and some files had suddenly dissapeared. I solved the errors also in windows and changed the assets in the referenced Events.
(Some weird thing happened there because FMOD and Perforce understood that those were new files, new assets, and I had to submitted them again to the source control).
After doing that, I was trying to build the banks on the project (for UE4) and then an error occured in the bank where I had those events.

This is the error:

Error processing /././Desktop/././././Source Assets/./FMOD Name/Assets (An operating system based file error was encountered.)

The same error is happening in the Windows project.

We are looking for solutions in the forums and everywhere but we have found nothing.
We have discovered that some xml files didn’t have a Name in the Path. We have deleted those files but we still have this issue.

This is the log errors we are having:

  • 15:11:07 [Build bank “OceanBank”)]: Time started
  • 15:11:07 [Write /Users/././././././UE4/Content/./Audio/FMOD/Desktop/OceanBank.bank to file]: Time started
  • 15:11:07 [Runtime]fmod_os_misc.cpp(220), FMOD_OS_File_Read(): fread failed, errno = 21
  • 15:11:07 [Runtime]fmod_systemi_sound.cpp(221), SystemI::createCodec(): Fatal error (13) scanning the codecs. (ie not FMOD_ERR_FORMAT or FMOD_ERR_FILE_EOF)
  • 15:11:07 [Runtime]Error processing /Users/././././././Source Assets/Music/FMOD…/Assets (An operating system based file error was encountered.)
    ! 15:11:07 “FMOD_ERROR (65536): Unknown error.”
    ! 15:11:07 “FMOD_ERROR /Users/raymond/jenkins/workspace/Build__1.10__Studio_Mac/studio/src/Model/Bank.cpp(150): modelBuilder.builder()->writeToStream(&stream, bankVersion, exportFlags)”
  • 15:11:07 [Write /Users/././././././UE4/Content/./Audio/FMOD/Desktop/OceanBank.bank to file]: Time taken is 46.51ms
    ! 15:11:07 “FMOD_ERROR (65536): Unknown error.”
    ! 15:11:07 “FMOD_ERROR /Users/raymond/jenkins/workspace/Build__1.10__Studio_Mac/studio/src/Model/Bank.cpp(164): buildBank(this, dataType, absoluteBinaryPath(platform, sBankSuffix(dataType)))”
  • 15:11:07 [Build bank “OceanBank”)]: Time taken is 149.55ms

If someone has a solution or an idea you are, please, welcome to share.
Best,
Celer

Looks like one of the events in the bank is doing something weird or has single instruments pointing to something weird. The error should point to an actual file whereas from the error dialog it looks like it’s pointing to a folder or something similar.

You can probably narrow down which event by making a new bank and assigning events in ocean bank to the new bank one at a time and see which event causes the error.

Could you also let me know if the ocean bank has an audio table?

1 Like

Hello Richard.

Thank you for the answer.
We were working on that and yes, we discovered that some files (xml) were pointing to nothing at all.
(All the files that have given us the problem before were on the same Event so we narrowed that quickly.)

It seems that looking for those files and deleting them in the Asset folders and the depot (plus deleting some cache files aswell) has worked and we don’t have the error anymore.

Thank you :slight_smile: