FMOD 1.07 not working for a specific person


I have implemented FMOD 5 1.06.3 in our game (we are multiple developers), everything worked like a charm, until we upgraded to FMOD 5 1.07.

One of the developers reported me that he couldn’t hear anything when I upgraded to 1.07, so I made several tests and everything works for me.
I asked him to check volumes/settings on his Windows 7 x64 and he told me that everything is fine.
I asked him to check every FMOD call on his PC with the debugger and he told me that every FMOD call returned “FMOD_OK”.
He tested on his GF’s PC and everything works. I tested on my dad’s laptop, my mother’s PC, my GF’s PC and even a friend of mine tested the game, all of them had musics/sounds.

This is what he tried and it didn’t worked :

  • Rebooting
  • Having only the headphones plugged in or the speakers plugged in
  • Upgraded to FMOD 1.07.1 (the latest version at the time I’m writing this)

He made a final test and I’m quoting him : “If I compile and run the game with FMOD 5 1.06.3, everything is working. If I compile and run the game with FMOD 5 1.07 or even 1.07.1, I can run the game but I don’t have any music/sound.”

I would like to know if anyone has this issue and how to fix it if possible because for the time being, downgrading to FMOD 1.06 will likely be our final extreme option left.

Thanks for reading and helping me.

This will be fixed in 1.07.02. As a work around lower the output rate of your device to 48000 in the Window’s control panel.

We updated to 1.07.2, the developer who had the problem confirmed me that everything is fixed and working.

Thank you again for your answer and the fixes ^^