FMod causes error when using remote mac compile

#1

When packaging for Mac from Windows using remote machine it is not possible to finish building because FMod is not using correct folders for their third party libraries. FMod binaries downloaded from this site are placed in FMod/Binaries but packaging deletes whole Binaries and Intermediate folder before every build. It thinks that binaries can be recreated using source but it is not possible as those libs are third party.

Here is the log: https://pastebin.com/ZD1bc9dK (4.21.1)

Look for libfmodstudio_iphoneos, you will notice that packaging deletes those files and then tries to build the project. I tried to immediately copy them on mac after delete and it worked. For now I modified Unreal Build Tool, so it completely ignores FMod binaries and placed them manually into Binaries folder on remote Mac. It is not nice workaround, so it would be nice to have that fixes, as it is probably issue on FMod integration side. I have seen that some other plugins from game DNA are using ThirdParty folder or Extras folder for their own binaries. Those plugins are working correctly in our project.

Rough repro:

Create c++ project with fmod
Setup provision and certificate on windows
Install xcode on remote mac
Configure IP and other remote settings in project settings
Package for iOS

0 Likes

#2

Thank you for reporting this, we will look into this further for a solution.

0 Likes