FMOD choopy sounds

Hi guys,

So I am working on the VR game in Unity. The FMOD audio plays fine when playing on the editor, but when I build the game the sound gets choppy. I have the following buffer warning on Unity console

I have increase the buffer size on FMOD and I have increased the virtual and real channel count on the FMOD settings inside Unity but it doesn’t work. Do you think this warning is related to the problem and do you have any suggestions to fix this?

Thank you in advance

This usually indicates that there are a lot of parameter changes or new sounds being created and destroyed at a high frequency. Are you creating and destroying lots of sounds every frame? If so you might need to optimize your audio usage by merging audio assets in your DAW or reducing the max instances of the offending events. You can identify these by using the Profiler and Live Update.
Otherwise, we recently made some changes to improve the dynamic expansion of the buffer size, so it might be worth updating to the latest 2.01 or 2.02 version depending on which one you are using.
It is strange that it’s happening only in built games though, what version of FMOD and Unity are you using?