FMOD crashes using non-OS USB audio drivers

Hi folks!
(using FMOD 2.2.18 with UE5.1)

Some of our developers using USB headphones (either bluetooth - Apple airpods, or TRRS to USB - Logitech, Corsair with manufacturer software) are experiencing audio crashes, garbled audio (persisting into OS after crash) or no audio when the first full level loads.

It seems to resolve on Windows when 3rd party software (such as Logitech GHub) is removed, perhaps allowing Windows to reinstate its ‘USB Audio Device’ driver.

I can see a history of related issues but not all confirm USB as being the cause.

Our Code team haven’t included any FMOD System Device callbacks or System::SetOutput instructions - could that be related, bearing in mind the devices aren’t changing mid-game?


Could I get some reproduction steps to cause the crash?

Is this happening in the UE editor or a packaged project?

Hi @Connor_FMOD sorry for delay this has been quite tricky to get more info on.
Not sure it’s related but I’m using Google Resonance.

the log mentions:

  • LogFMOD: Error: ‘System->setListenerAttributes(ListenerIndex, &Attributes)’ returned ‘Not enough memory or resources.’
  • LogTemp: Error: Memory leak in ECS memory pool (edited)
  • LogFMOD: Error: ‘bankArray[i]->unload()’ returned ‘Not enough memory or resources.’

Repro steps involve just playing our game normally it seems, might be a code issue then.

Are these kind of runtime stats reasonable?



No, these look very high.

Could you please collect a profiler capture while reproducing this issue in game, then package your profiler session including banks (ticking the “Banks” option when exporting), and upload it to your FMOD Profile?

Have you disabled the UE Audio system? Having both enabled can cause issues when it comes to resources.

Will do asap

Is there a recommended way to disable unreal audio? Our coder is adding -nosound to the ini

I’ve reduced memory by removing bypassed fx, is this more reasonable?
wondering why Global Memory is showing a negative value…
Thanks for help @Connor_FMOD

1 Like


Instructions for disabling UE audio can be found here: Unreal Integration | User Guide - Disabling Unreal Audio Device.

That is good progress, but having negative values is strange. Hopefully, the full profile package will help solve this.

Hi, i disabled Streaming Assets and the value normalised so that was not it.

I can now repro it using low quality BT headphones by going to a certain part of the world map where there are corrosion sfx. One of our playtesters has said that by selecting another audio input before booting game, then switching to the correct input after game loads into menu prevents the audio dropout - I can confirm this. Bug - Audio :: TerraTech Worlds General Discussions

Does that suggest that our game code is loading the FMOD system prematurely or perhaps improperly somehow, and it’s only flagging on low quality BT/USB headphones when certain sfx trigger? Or possibly some code leak elsewhere or even FMOD event causing it - the profiler disconnects when this happens so not useful, and the game sfx instances creep up into high numbers.

PS I’m not sure if we have the level of support that enables me to assign the game to my FMOD profile


You can register a project no matter the level of support.

Unfortunately, without more information, I do not know. Are there any UE logs that you can share when the game crashes? Or would it be possible to get a copy of your UE project or a stripped-down version displaying the issue uploaded to your profile?

Hey Connor,

It seems that events Virtualising is the cause, it’s as if the code doesn’t recognise it and it just starts leaking, causing audio to choke without crashing the game, but only using certain audio hardware.

I have disabled most of it but there are enemies that need to Virtualise otherwise they mute when out of range - I’ll let you know if we find out why it’s happening!

1 Like


Yes, please keep me updated.

Thanks for sharing your solution, though this does sound like a bug.