FMOD not showing third party plugins


I’m using cabbage to make an FMOD plugin with Csound but FMOD refuses to show me that plugin when I try to add a plugin instrument.

Meanwhile, a friend of mine is able to export the exact same Csound code as a plugin through Cabbage and have it and other plugins show up when he adds a plugin instrument.

We are both on MacOS and we have the exact same version of FMOD (2.00.10) and Cabbage (2.3.0). I’m inclined to think the problem might be on the FMOD side of things since it also doesn’t show other third-party plugins I downloaded to test. I’m attaching a screenshot of my Plug-ins folder path setup on FMOD. There are also no error messages on the FMOD console.

Truly at a loss on what could possibly be wrong with either FMOD or Cabbage, is anyone ale to offer me any guidance or possible solutions?

Thanks in advance!

Given that your friend is able to get it to work, the issue is almost certainly caused by your machine’s unique settings or setup.

The lack of error messages suggests that FMOD Studio isn’t detecting the plug-ins at all, which might mean it’s not looking in the right place for them. Try setting your plug-ins folder to a different path, preferably one with only alphanumeric characters and slashes, and see if that helps.

When you export your procedural instruments in Cabbage, are you sure you’re exporting them as “FMOD Plugin Sounds?”

If a directory is subject to source control, or automatically sync’d to an online file hosting service such as Dropbox, this may interfere with FMOD Studio’s ability to write to files in that directory. This is unlikely to cause issues for most plug-ins, but may be worth investigating if changing the path doesn’t help.

What path have you installed FMOD Studio to? FMOD Studio often has trouble accessing the file system if run from inside an archive rather than installed from that archive to a path.


Tried setting the plugin folder to another path using only alphanumerical characters and that didn’t work.

I am exporting it as FMOD plugin sounds in cabbage and moving both the .dylib and the .csd files to the plugins directory I’m using.

As far as cloud syncing, I’m using Backblaze for automatic backups. I tried pausing it and running FMOD again but no luck either.

I’m running FMOD from Macintosh HD > Applications > Library. Would you recommend moving it to another path?

Thanks for your help!

With regard to automatic syncs, I also use ChronoSync but it’s only backing up from my internal to external drives. Do you think that might be an issue? I tried to run FMOD again after quitting ChronoSync but that didn’t work either. Do you think just by having both ChronoSync and/or Backblaze installed that would be an issue?

Just tried using the system plug-in directory and the project plug-in directory, those are also not working and no error messages are shown in the console.

A little update on this: I’ve reformatted my computer and FMOD is still not recognizing the plugin.
Two other people have also tried the plugin. One of them could make the plugin work, another one couldn’t. Below are the FMOD console outputs the three of us are seeing:

MacOS High Sierra, plugin not working:

MacOS High Sierra, no problems with the plugin:

macOS Catalina and Mojave, plugin not working (this one is my FMOD’s console)

We were all using the exact same plugin files. I’d really appreciate if anyone could offer any more insight into this since I’m completely clueless as to why this is happening. I can also send you the plugin files if you are willing to test it on your system. Thanks :slight_smile:

Final update on this: I downgraded my MacOS back to High Sierra and it works now. There were no changes in my console output either, it remains the same.