Cabagge/Csound issue in FMOD Studio


I’m a new user of FMOD. Currently I’m developing an educational training software in Unity and Cabbage is the answer for two simple dsp processing jobs that FMOD can’t do.

I have programmed a simple phase invert plugin and the VST version works perfectly. The issue is when I export the FMOD version and I add it to the proyect in the FMOD studio the sound is weird, like dropped samples and pitch alteredsound. I have even tried to use the example plugins with the same result.

I have experimented with the sr, ksmps, number of channels, etc, with similar results.

Someone have similar problems? I’m using the latest versions of both software in mac and windows. nieve checked earlier FMOD builds back to 1.08.

Thanks in advance.


I am not familiar with cabbage audio, but if the pitch is out that could be caused by sample rate, and if you are getting dropped samples that could be an incorrect buffer size. Does changing your OS’ sample rate affect the result at all?


I’ve tried changing the SR in OS and SR in the code of the plugin with no success. After some work, the cabbage plugins seem to work in PC in FMOD build 1.10.05.

I’ve to made an entirely new project to use that build.

I’ll keep you informed.

Thanks for your help

Hi everyone!

Sorry for the delay. I’ve solved the problem. It seemed to be an issue when the track is a wav mono file in FMOD. A colleague check the cabbage plugin with a stereo wav file and it worked!
The solution is to place a very short wav stereo file at the beginning of the mono track and the cabbage plugin works perfectly the rest of the track even with mono files.

Thanks and I hope this helps someone.


1 Like