FMOD Studio not working on Android 6.0.1?

After updating my phone (Galaxy S7 Edge) to Android 6.0.1 there is no longer any sound in my Android build, whereas the Unity Editor works just fine. Are there any known issues with the latest FMOD Studio and 6.0.1, or any other ideas to what it might be?
I am using FMOD Studio 1.08.15, Unity 5.1.2 on OS X 10.11.16


There aren’t any issues I am aware of, are you getting any errors or warnings?

No errors that I can see, no. The only thing I can think of that’s changed since the last time I tested the build is the Android update, and in previous builds everything worked fine.

EDIT: I’ve located the problem, and apparently FMOD fails to initialize in the Android build due to the plugins fmod_noise and fmod_distance_filter.
After checking LogCat I get this message:

01-12 15:58:22.028: I/Unity(15250): (Filename: Line: -1)
01-12 15:58:22.038: I/Unity(15250): SystemNotInitializedException: FMOD Studio initialization failed : Loading plugin ‘fmod_noise’ from ‘/data/data/com.MyCompany.MyProduct/lib/’ : ERR_FILE_NOTFOUND : File not found.
01-12 15:58:22.038: I/Unity(15250): at FMODUnity.RuntimeManager.CheckInitResult (RESULT result, System.String cause) [0x00000] in :0
01-12 15:58:22.038: I/Unity(15250): at FMODUnity.RuntimeManager.Initialiase (Boolean forceNoNetwork) [0x00000] in :0
01-12 15:58:22.038: I/Unity(15250): at FMODUnity.RuntimeManager.get_Instance () [0x00000] in :0

I’m guessing I need to place the plugins in the appropriate folders? I’ve put both libfmod_noise and libfmod_distance_filter in the Assets/Plugins/Android folder, but still no luck. Any pointers?

The problem with using those plugins is that they are intended to be examples of how to make your own. The libs that come with studio will only work on Windows/Mac, to get these to work on other platforms you will need to download the FMOD API and build the plugins for the required platforms (from the examples).

1 Like