FMOD Studio requires glibc 2.27 which is too new for my Linux distribution


Thank you for adding Linux support to FMOD Studio (2.02.01)!

I’m running openSUSE 15.2, and although it’s one of distributions using rpm packages instead of deb packages (as you provide), I would manage to run FMOD Studio here anyway if not for a harder issue:

My distribution has glibc version of 2.26, which is older than required by FMOD Studio:

> ./fmodstudio
./fmodstudio: /lib64/ version `GLIBC_2.27’ not found (required by /home/igor/build/fmod/studio/opt/fmodstudio/lib/

> ldd --version
ldd (GNU libc) 2.26
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
Written by Roland McGrath and Ulrich Drepper.

I would appreciate if you built FMOD Studio against older glibc to allow for non-Ubuntu distributions to run it too!

Looks like FMOD Engine libraries for Linux already don’t have this issue, so it shouldn’t be a big deal.

Hi scorched,

Reducing the glibc version requirements for FMOD Studio is considerably more difficult than reducing it for the fmod libraries due to its additional dependencies. However, we will look into seeing if we can slightly reduce the required glibc version.

1 Like

After investigation, we have found a way to reduce the required glibc version to 2.17, which will included in our next release. It should be noted that the glibc version required by the api for x86_64 on linux is only 2.2.5, so the studio requirement is still significantly higher.

1 Like

This is great news, many thanks, guys!

BTW I believe openSUSE 15.3 will increase the version of glibc packaged, which also would solve the issue at least for my distribution of Linux.