FMOD/UE4 - transitions not triggering


#1

Having an issue with transitions; set up a parameter to jump between parts of the track using destination markers, works as expected within fmod, but when in UE4 the transitions are ignored. The track starts at the beginning and loops after it reaches the parameter setting, but the regions never trigger to jump to the next part.

I had this problem with a previous event, and created a test event which worked perfectly with the same setup, Now I’v created another event and again the transitions are ignored. Everything works in FMOD and the profiler shows the switching taking place, but the transitions simply refuse to trigger within UE4


#2

Managed to get around this by leaving .5 either side of my transition value :face_with_raised_eyebrow:


#3

If leaving a .5 on either side of your transition values worked, the problem must have been a float rounding error, e.g.: the value being fed to the parameter by UE4 was 4.0000021 instead of exactly 4, and so did not meet the parameter condition.

Unfortunately, there is no way for us to predict when game engines will produce rounding errors, so the only solution is the one you have discovered: Add a small buffer on either side of any transition condition.