Force audio to Mono in Banks

Hey there! I’m new to FMOD and have searched everywhere (Documentation, Forums, Google, etc) trying to figure out how to force the audio files to save as Mono in the banks.

I come from Unity where we can select “Force To Mono” on the audio files which saves quite a lot of memory and build size for mobile. Is there no equivalent on FMOD?

Unfortunately, there is currently no way to do this in FMOD Studio. FMOD has a focus on handling audio at runtime, not at build time - other audio programs like DAWs handle build time, while FMOD handles runtime.

As such, while you can specify the channel format of banks for a given platform (Edit → Preferences → Build → Project platforms), this only applies to spatializer effects, return buses, and the master bus output - not the asset files that make up a bank. If you need to downmix your audio assets, we recommend doing so in your external audio editor of choice.

With that said, if size is a concern for specific platforms like mobile, you can set custom encoding settings on a per-platform basis (also from Edit → Preferences → Build → Project platforms), which will compress your assets when building banks for a given platform.