Getting an error when trying to save project


Recently I started to get a lot of issues with project, which are usually fixed by “Validate project” - everything seems to work fine, though it’s an annoyance too.

But today I got this when I tried to save a project .

I’ve seen a couple of threads with similar issue dated 2014 and 2017, and it was said that this was fixed, but I’m having this issue now with FMOD 2.02.07 64-bit running on MBP 2021 M1 Pro, Sonoma 14.1.1

I’ve tried to move the project out of iCloud synced folder, but I get the same result.



The error you’ve received should only occur when a file explicitly isn’t writeable, or if a renaming was unsuccessful. If it’s the former, you may need to manually make the files writeable. Do you receive any additional messages in the FMOD Studio console when receiving this error?

We have had users report similar issues with saving to projects located in an iCloud folder, which would be the most likely culprit, but you’ve stated that you’ve tried to move the project out of your iCloud folder - can you elaborate on your exact process? Additionally, if you create a new version of the project on a local disk using File → Save As, do you still run into the issue?


While using FMOD recently I’ve received messages like “Project has issues, try to validate it” (something like that), and once I press “repair”, everything seems fine, though it will reappear on next launch. But what I’ve noticed is that all VCA’s are gone, and some events lost their routing (they are located in root directory of Routing tab, instead of being under specific Groups).

I’ve simply used Finder to copy files from iCloud to local storage. Now I’ve tried “Save as” method as you’ve mentioned above. Everything works fine until I try to create VCAs. Once I’ve created them and assigned groups to these VCAs, I start to get same errors that I’ve received before.

I’d suggest copying the files from iCloud to local storage and making them all writable. If they’re not writable then that may be the cause of these errors. If the problem still persists when all the files are writable, can you try an experiment for us please? Download the latest version of FMOD Studio (2.02.20) and see if you can reproduce the problem? Thanks.