Fmod 2.00 Project not saving!

Hi guys

For some reason I opened the fmod tutorial project that I’m working on yesterday and woke up today with most of my work not saved when I was sure I saved it.

Now been continuing my work (and my implementation was successful), however as you can see in the pics the save is not updating. ‘Date modified’ remains the same. I’m scared to close the project and it won’t reopen again with the new changes made.

‘Saving As…’ does seem to solve it but I cant do that each time.

Oddly enough, since I created a new “save as…” and made 1 save after it and it worked and updated in the ‘date modified’ (about a minute after I created a new save as) but it hasn’t updated ever since even though i saved many many times.

Please help this is serious.

(I tried to post more than one pic but couldn’t cuz im a new user)


Here is pic 2 with the time of when I took the screenshot and made a save

I made a save at 5-ish pm as you can see.

Please let me know what to do. I don’t want to keep ‘saving as’!

From the look of your first screen shot it seems like your FMOD Studio project is under some kind of source control. Can you confirm that you have checked out this project and none of the folders/XML files/etc are locked?

Sorry Im not sure what you mean by that.

Nothing happened or changed to these folders thats out of the ordinary.

Can you please clarify?

Your folders in the first screenshot (and not the fspro project file) have blue arrows on them. It looks like this means they are either in source control or kept in a backup system like Dropbox or OneDrive. If they are, there’s a chance these softwares are “locking” the files when you try to save changes to them, and that causes the project to not save properly.

I removed the blue arrows, apparently they’re used to compress disk space on the SSD. It added space to my PC but didn’t solve the issue unfortunately. Very odd.

Is it weird the project file is only 88 bytes in size? and it says 0 bytes on disk.

Windows 10 btw on a very decent rig.

FYI i can see it save normally inside FMOD (i see for a snapshot of a sec a save progress bar)

This is certainly strange. Saving keeps changes between all projects I have tested.

Can you try creating a new project, make some changes, save, and then close & reopen that project? Does the project keep its changes between those states?

Could you also provide the following information:

  • Is this project (“Fmod Proj Starter Tutoria_2l”) a freshly create project or one that you have downloaded?
  • How are you opening this project? Are you double clicking on the fspro file, using File > Open, or using the recently opened list on the welcome popup at startup?

In regards to the file size, the actual fspro file is just the metadata for the project. It being small is expected.

Hello Richard

Yes strange indeed.

Even stranger, I opened a new project, made some changes, and saved. However it did create a save file, it never updated after that. Same issue… really weird…

In regards to your questions:

  • The project file is a ‘save as…’ from the same project that won’t save. ‘Save as…’ is the only way I manage to save something

  • The way im opening it is through double clicking the project file inside the folder.

I closed the program and lost some work but it’s ok nothing serious this time. But I can’t use the software obviously until I find a solution. Should I try re-installing or is there something else that comes to mind?

Let me know please.


It seems so far everything is working althought ‘date modified’ doesn’t appear to change. I think i misinterpreted from the first time probably because i forgot to save before quitting.

I’ll experiment tomorrow and let you know.


Any update on this? It seems that there are issues with the project being saved on Mojave.

What issues are you seeing on Mojave?

@richard_simms I teach game audio courses and several students who have upgraded to Mojave all have issues with various versions of FMOD from 1.x to 2.x. The issue seems to be that the project shows the save progress bar but the date / time doesn’t update on their local drive. When the project is saved, closed and opened again the audio assets are often missing from the events and sometimes the events are missing as well. The audio assets seem to remain in the audio bin.

That sounds worrying. Could you please verify some info:

  • Where are the projects being saved? Are they saved on the local Mac machine, external storage, or a network drive?
  • Are these Macs on a network, such as in a school? If so do these machines have any kind of permissions on them set by the systems administrator?
  • If you open the logs (Windows > Console > Logging) and save the project does any error message appear here?

@richard_simms One of the projects were saved on the local HD and another was saved on an external. The computers were all student owned so I am not sure about permissions. One student was able to work with the project just fine before updating to Mojave. The other student started out with Mojave.

No errors were found in the project upon running Validate Project. The only thing that stands out to me in the log is:

11:00:44 fmod_systemi.cpp(2822), SystemI::init(): Output requires a sample rate of 44100Hz, resampling will occur.

I’ve attached the log from one session below.
log.txt (25.7 KB)

Did you save the project before grabbing the logs? I’m not seeing the [Saving project]: Time started log in your log file.

@richard_simms I did save before getting the logs.

I have tried using a Mojave MacBook with latest updates but I can still save a project without issue.

I did notice that when starting FMOD Studio for the first time it asked for permission to read/write to certain folders.

Could you please go into System Preferences > Security & Privacy > Security and add FMOD Studio to “Full Disk Access”. Let me know if this helps.

Thank you. I will give it a try.