Getting Multiple Errors When Integrating FMOD Project into Unity Game - Please Help

I am working on a game in Unity 5.5.2 but when I try to import my FMOD project I get 999+ errors all along the lines of the following:

BankLoadException: FMOD Studio could not load bank ‘/Users/Hazel/Documents/MSc SOUND DESIGN/FINAL PROJECT/HT_FMOD Designs/Build/Desktop/Master’ : ERR_PLUGIN_MISSING : A requested output, dsp unit type or codec was not available.
FMODUnity.RuntimeManager.LoadBank (System.String bankName, Boolean loadSamples) (at Assets/Plugins/FMOD/RuntimeManager.cs:629)
FMODUnity.RuntimeManager.Initialiase (Boolean forceNoNetwork) (at Assets/Plugins/FMOD/RuntimeManager.cs:285)
FMODUnity.RuntimeManager:Initialiase(Boolean) (at Assets/Plugins/FMOD/RuntimeManager.cs:289)
FMODUnity.RuntimeManager:get_Instance() (at Assets/Plugins/FMOD/RuntimeManager.cs:79)
FMODUnity.RuntimeManager:SetListenerLocation(Int32, GameObject, Rigidbody2D) (at Assets/Plugins/FMOD/RuntimeManager.cs:848)
FMODUnity.StudioListener:SetListenerLocation() (at Assets/Plugins/FMOD/StudioListener.cs:42)
FMODUnity.StudioListener:OnEnable() (at Assets/Plugins/FMOD/StudioListener.cs:21)

I also get "BusNotFound’ Exceptions and ‘EventNotFound’ exceptions. I’ve spent 3 days trying to fix this and I’m at my wits end! Please can somebody help? I was initially using the oculus spatializer plugin in FMOD and thought that might have been causing the problems as Unity could not seem to see the plugin (despite it being in the correct assets folder, etc.) However, I tried importing an ordinary FMOD project (sans Oculus plugin) and I’m getting the exact same errors. I’ve never had any issues with FMOD/Unity before and I don’t know what to do.

Have a look in FMOD > Log Viewer. It will tell you what plugin you are missing.

Most likely it is the FMOD Distance Filter or FMOD Gain. These plugins aren’t included in the Unity integration package.

To fix this, in FMOD’s (the app) folder there will be these two plguins’ DLL files. Copy these into Assests/Plugins/x86_64 and in FMOD’s settings, click ‘Add Plugin’ and add the name of the plugin without the .dll. It should look like ‘fmod_distance_filter’ rather than ‘FMOD Distance Filter’ as you’re copying the name of the file, not what it is when looking pretty.

Hopefully that will fix your error! Just reply if you’re unsure on something.

1 Like

Hi James, many thanks for your reply - really appreciate it. It’s noting the Oculus Spatializer as missing…but this is one of the reasons why I thought it might be that plugin that’s causing the issue - it’s already there.

I’ve added it following the Oculus developer page instructions, and did the ‘add plugin’ step in the FMOD setup for Unity, but for some reason it just isn’t seeing it when I try to play the game. What’s weird is it’s still saying the oculus spatializer is missing when I import an FMOD project without any oculus spatialisation… That’s what made me think perhaps it’s an FMOD issue. I could be wrong!

Just to update on this. It’s most likely I have a corrupt master bank…possibly a corrupt project. Rebuilding the banks hasn’t fixed it, and copying the events manually from the corrupt project to a new one and building a new bank just triggers the same errors. Does anyone know of any way to salvage a corrupt project?

I would be leaning more towards the way the plugins are setup, as James mentioned, by default if FMOD cannot find a plugin it won’t load the banks.

ERR_PLUGIN_MISSING will mean the plugin hasn’t been named in the settings.
ERR_FILE_NOTFOUND will mean either the name doesn’t match or it’s looking in a different folder for the plugin. If you get this error it will tell you exactly where it is looking for the plugin and the name it is expecting.

1 Like