How to prevent banks to be included in the build

Hi, I’m using FMOD to create a DLC for my game. I separate the dlc content into T_Chapter1 and T_Single banks. However, when making a build, all banks including dlc banks will be packed into the build. Can I manually include or exclude banks in the build?


Excluding/including specific banks is possible, but requires some scripting on your part as you’ll need to be manually building and loading assets using Unity’s AssetBundle functionality.

We have documentation on using AssetBundles and Addressables with FMOD - to summarize, you’ll want to:

  1. Swap your Import Type in your FMOD settings in Unity from Streaming Assets to Asset Bundle.

  2. Create separate AssetBundles for your core and DLC banks using the generated stubs.

  3. Use a script to manually handle which of your AssetBundles to build and include in builds.

  4. Use a MonoBehaviour script to handle loading banks from your AssetBundles at runtime.

If you haven’t already, I would also recommend taking a look at our documentation on supporting downloadable and user-generated content.

Hope that helps!