Installing FMOD on Raspberry Pi

Hi there,

I’ve been trying for the last few weeks to install FMOD on my raspberry pi model b but I’m running into an issue where when I run one of the provided examples, it fails with the error “ cannot open shared object file: No such file or directory”

I originally tried following the directions here: but they seem to be outdated. So the following are notes that I took that got it almost working. Please help!

  1. Download Fmod Ex (the Programmer Api) from the FMOD site
  2. Copy FMOD tar.gz file to root on your pi Untar it using tar -xvzf: tar -xvzf
  3. Navigate to fmodstudioapi10813linux/api/lowlevel. I have a Raspberry Pi Model B
    so I’m using the shared library (.so files) in the lib/arm folder.
  4. sudo cp fmodstudioapi10813linux/api/lowlevel/lib/arm/libfmod*
  5. sudo cp fmodstudioapi10813linux/api/lowlevel/inc/.h /usr/local/include/
  6. The next thing is to test if everything is in working order. Run “Cd
    make” // to change directory into the make folder under
  7. “make --file
    play_stream.makefile CONFIG=Debug CPU=arm” this failed with the
    following error “ /usr/include/arm-linux-gnueabihf/gnu/stubs.h:7:29:
    fatal error: gnu/stubs-soft.h: No such file or directory # include
    <gnu/stubs-soft.h>”, so I changed my makefile such that
    “-mfloat-abi=softfp” became “-mfloat-abi=hard”.
  8. Now I get the error
    “ cannot open shared object file: No such file or

Have you tried the ‘armhf’ libraries?
I believe Raspbian uses the hard-float ABI which those libs are designed for.

Is there a updated guide on how to install fmod studio on a raspberry pi 2?

If like the original poster intended you mean installing the FMOD Studio library, it’s simply a matter of unpacking the tar.gz linking you applications with and including the headers directory. We ship example Makefiles for you to use as reference.

If you mean installing the FMOD Studio tool, it is not compatible with Linux.