Issue with UE4.25 when running the game in editor

    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000000

UE4Editor_FMODStudio!FFMODStudioModule::UpdateListeners() [G:\Perforce\Prometheon\Plugins\FMODStudio\Source\FMODStudio\Private\FMODStudioModule.cpp:847]
UE4Editor_FMODStudio!FFMODStudioSystemClockSink::TickRender() [G:\Perforce\Prometheon\Plugins\FMODStudio\Source\FMODStudio\Private\FMODStudioModule.cpp:140]
UE4Editor_Media!FMediaClock::TickRender() [G:\Epic Games\SpatialOSUnrealGDK-4.25\Engine\Source\Runtime\Media\Private\MediaClock.cpp:93]
UE4Editor_Media!FMediaModule::TickPostEngine() [G:\Epic Games\SpatialOSUnrealGDK-4.25\Engine\Source\Runtime\Media\Private\MediaModule.cpp:97]
UE4Editor_UnrealEd!UEditorEngine::Tick() [G:\Epic Games\SpatialOSUnrealGDK-4.25\Engine\Source\Editor\UnrealEd\Private\EditorEngine.cpp:1742]
UE4Editor_UnrealEd!UUnrealEdEngine::Tick() [G:\Epic Games\SpatialOSUnrealGDK-4.25\Engine\Source\Editor\UnrealEd\Private\UnrealEdEngine.cpp:414]
UE4Editor!FEngineLoop::Tick() [G:\Epic Games\SpatialOSUnrealGDK-4.25\Engine\Source\Runtime\Launch\Private\LaunchEngineLoop.cpp:4850]
UE4Editor!GuardedMain() [G:\Epic Games\SpatialOSUnrealGDK-4.25\Engine\Source\Runtime\Launch\Private\Launch.cpp:169]
UE4Editor!GuardedMainWrapper() [G:\Epic Games\SpatialOSUnrealGDK-4.25\Engine\Source\Runtime\Launch\Private\Windows\LaunchWindows.cpp:137]
UE4Editor!WinMain() [G:\Epic Games\SpatialOSUnrealGDK-4.25\Engine\Source\Runtime\Launch\Private\Windows\LaunchWindows.cpp:268]
UE4Editor!__scrt_common_main_seh() [D:\agent\_work\9\s\src\vctools\crt\vcstartup\src\startup\exe_common.inl:288]

Thanks for reporting this. There is an unchecked pointer dereference at the location where the exception occurred so we will schedule a change to add a null check.

We would not have expected that pointer could be null though so I’d be curious to know more about this crash if it’s possible. Are you able to provide any more information about steps to reproduce the crash?

Just followed the steps from docs.

I enabled the plugin, added the dependency to build.cs.
after building successfully when I ran the UE4 Editor and pressed play. That’s when I get the crash.
no other steps taken.

Also I am using the UE4.25 SpatialOS Build. I don’t think this would matter but just wanted to let you know.

Thanks for the additional information. I haven’t been able to reproduce the issue but from the crash dump it seems certain that the unchecked pointer dereference is at fault. We’ve added a fix for that to our integration in 2.00.13 and 2.01.05, which are currently in QA pending release.

I don’t believe there is a workaround here. If you are working with a C++ project and feel comfortable making a change to the FMOD UE4 plugin source it’s a very simple fix which you could apply yourself. In the file Plugins\FMODStudio\Source\FMODStudio\Private\FMODStudioModule.cpp, in the function FFMODStudioModule::UpdateListeners change lines 846 and 847 from this:

            UGameViewportClient *GameViewport = PieContext.GameViewport;
            UpdateWorldListeners(GameViewport->GetWorld(), &ListenerIndex);

to this:

            if (PieContext.GameViewport)
                UpdateWorldListeners(PieContext.GameViewport->GetWorld(), &ListenerIndex);

If you’re unable to modify the plugin source code and the issue is blocking you then the best option would be to rollback to the FMOD UE4 integration for 2.00.11 or 2.01.03.

Thanks a lot @Darek really appreciate the help.

1 Like