Libresonanceaudio.prx not updated for PS4 SDK 8.50

We are using the Unity package “fmodstudio20110ps4_sdk8.500”, but the PS4 validator throws the error “Format of the SELF file is not valid. (libresonanceaudio.prx, SDK version must be 08.50x)” and outputs “libresonanceaudtio.prx: SDK version (module_param) = 08.008.011.”

This was also tested in an empty new project and the same error is thrown.

Is there a download of libresonanceaudio.prx that is built for SDK 8.50? Thanks!

I’ve uploaded a new build of fmodstudio20110ps4_sdk8.500 which has resonance built against 8.500. Look for it on the main Download page - it has the “patch 1” designator.

1 Like

Hello I am looking for this patch file, but can’t find it, could you link it here please?

Go to the main Download page, click on the Unity Integration section, on the right side of the screen click on “All” (not “Unity Verified”) and then select 2.01.10 from the version dropdown box. You should see the patched version listed.

Thanks Andrew

I have installed this patch version yet still I get an error

Assets\Plugins\FMOD\src\EventReference.cs(9,21): error CS0234: The type or namespace name ‘GUID’ does not exist in the namespace ‘FMOD’ (are you missing an assembly reference?)

I am using fmodstudio20110 + the patch ps4 file you provided.

Advice please
Thanks
Sandman

Go to the main Download page, click on the Unity Integration section, on the right side of the screen click on “All” (not “Unity Verified”) and then select 2.01.10 from the version dropdown box.

Apologies for the delay. What Unity version are you running?