Looping same asset in multisound


(Jan Ondra) #1

Hello,
we are working on a game where I composed random music. (3 parts in 3 multisounds. Each part contains 4 sounds, every sound works with the others in harmony). Every sound is 8 bars long and I want to loop the second half of the 8 bars because of overlapping reverbs) Problem is, when the timeline reaches the end of the multisound, different sounds are being picked upon looping which I dont want. I just want to pick different sounds with each event calling, not with the looping. Is there a solution for this please? (in short: Event starts, picks 3 different sounds that are now playing simultaneously in sync. When they reach 8th bar, I want them to loop from the 5th to the 8th. Problem is when they reach the end and jump to 5th bar, different loops are beeing picked from the multisounds, I want the old ones to loop)


(リチャード清水) #2

Hi Jan,

If you were to install FMOD Studio 1.10.04 you will have the ability to set the number of loop counts for each individual playlist item in a multi instrument. You can use this to make sure the sound file for bar 5 to 8 repeat.

If you cannot update to 1.10.04 then you will need to externally extend the audio file outside of FMOD Studio so that it plays twice. Failing that you can duplicate the audio file and disable the randomised playlist function so that you are guaranteed the audio file to play twice.

I hope this helped,
Richard


(Jan Ondra) #3

Didnt help, maybe Im doing something wrong. Im attaching 2 pictures.

Picture 1: 3 Files are playing upon playing the event, this is ok.

picture2: The 3 files has changed upon arriving to the end of the loop and now we hear 3 different files playing from the bar 5.

I want to loop the 3 files that started the event, not change them.
The game is about space relaxation, where the player can for example touch a sun and move it around. For that I would like to play the event and keep playing the same sounds to the point the player releases the finger from the screen. Only after the player touches the screen again, 3 different sounds will start playing and so on.


(リチャード清水) #4

Hi Jan,

I see, thank you for the screenshots.

If you transition to another point in the timeline (eg. with a loop region) within the same multi instrument it will trigger the next item in the playlist. This is because you cannot seek within a multi instrument.

What I would recommend instead is to use 1.10.04. Set each playlist item in the multi instrument to loop the parts you need to loop indefinitely, enable the multi-instrument’s async and cut, add a loop region that has a small gap after the end of the multi instrument, and finally have a sustain point.

Here’s a screenshot to help.

https://imgur.com/eSUoM6G

You will need to have the looping parts externally edit the audio file to loop at the measures you need.

Thanks,
Richard


(Jan Ondra) #5

Oh, the sustain point kinda works. Didnt know it exist. One more thing Im confused about. What do you mean by “You will need to have the looping parts externally edit the audio file to loop at the measures you need.” ? Now Im in a point where the 1 file loops, but it loops all the 8 bars and Im not sure what you mean by that sentence :slight_smile: ANyway thank you for your help so far.


(リチャード清水) #6

Hi Jan,

What I mean is that if you want to only loop specific bars, you will need to trim the audio file to those bars. FMOD Studio cannot loop specific points in an audio file in a multi instrument, which is why it loops all 8 bars.

Thanks,
Richard


(Jan Ondra) #7

What if there is reverb tail on the 5th bar so I want to play from 1st to the 8th and return to the 5th for the tail to finish?


(リチャード清水) #8

Hi Jan,

I would recommend removing the baked in reverb from the asset and using the FMOD reverb instead.

Thanks,
Richard


(Gabriel Naro) #9

Hello Jan,

I don’t know if you still need this answer but I came here looking for the exactly same info. I solved this differently (properly/less hacky?), this was my solution.

Try to set the multi-instrument like this:

ASYNC ON
LOOP PLAYLIST ON

then you go into each loop inside the instrument and set LOOP SOUND to ON.

This did it for me on FMOD 1.10.01