Multichannel wav files output as stereo in editor


(Chris D'Arcy) #1

I’ve exported 10-channel wav files, and other files with varying numbers of multi-channel. No matter how many channel above two that I export (using Sound Forge 11) when imported into FMOD Studio, the program recognises the number of channels, shows the separate waveforms but plays the file summed to stereo and I have no idea why. I’ve checked after export and the files haven’t been summed. It’s 44.1k 16bit 10 channel wav but still coming out as stereo.

Is there a setting in Studio that needs changed or am I doing something wrong?

Thanks.


(リチャード清水) #2

Hi Chris,

Could you check your output device in the Preferences dialog? You might need to enable the correct device to properly hear all channels. For example, if you’re using headphones you might want to enable Windows Sonic.

Also, could you let me know how you can tell it is being summed to stereo? Are there multiple channels showing metering in the tracks/master bus? Check what the current project’s build is set to as well.

Thanks,
Richard


(Chris D'Arcy) #3

Enabling Windows Sonic hasn’t changed anything, all 10 channels are still being summed to stereo. Whenever I drag a multichannel wav into the audio bin, it shows as a single with ten waveforms, as I would expect. But when I import the file to and event, all ten channels are output to the left and right of stereo, in alternating order I believe. No matter what the input and output of the event are changed to and the build settings, the output on the meters only ever shows a signal on two of the meters - stereo.


(リチャード清水) #4

Hi Chris,

My mistake, I thought you were talking about the output being downmixed.

From the looks of it, any multi-channeled audio file above 7 channels will get auto-downmixed if it does not have the exact number of channels FMOD is expecting. 7.1 (8 channels) and 7.1.4 (12 channels) work fine in our testing, but 9, 10, and 11 channel files have this downmix issue you are experiencing.

I have raised a task in our tracker to investigate this further. Thanks for bringing it to our attention.

In the meantime, if you make the channel count 7, 8, or 12 for your file it should work fine.

Thanks,
Richard