Mono output of stereo sounds within multi sound event module

This problem occured in my project when I updated FMOD studio to the latest version. I have a multi sound event module (I see it as a parent module) which contains various event sounds (child modules) that are stereo music tracks. Playback in each of these nested events (child modules) is Stereo but when I attempt to monitor playback from the parent module I get Mono playback.

To visualize the hierarchy more simply:
“Master” Event -> Event -> Multi Sound Module -> Nested Event

This issue hasn’t been the case until I updated FMOD studio to the latest version - 1.07.00 and not only this mono playback is a problem but the parameter changes from the “Master” event that used to affect the playback within all these nested events don’t work anymore, plus all my custom mixer views have disappeared from the project (but that’s another topic). I don’t know exactly what version I used before but I do know it was last year’s.

I created a completely new event with the same hierarchy and it works just fine, so my question is do I really have to do it all over again or is there an easier solution to fix these problems?

Thanks in advance


I am unable to reproduce the channel format and the parameter issue using a new project created in 1.06 and migrated to 1.07. It could be something specific to the way things are setup in the event or project. In that case, it would help if you could contact us via and send us a copy of the project for debugging purpose.

The issue appears to be introduced in 1.07.00. We have managed to track down the cause of the problem and it will be fixed in patch release 1.07.01.

Once you’re running on 1.07.01, you’ll also want to right click on the affected events in the browser, and select “Refresh Output Format”, which should make sure any issues are corrected.

Apologies for any inconvenience caused.

Hi, I’m still experiencing this problem in version 1.08.02 - a multi sound is playing back stereo files as mono, but a single stereo sound placed on the same channel plays back as stereo as it should. I also removed the 3D panner to play back the sounds as 2D.

Hi Tom,

I haven’t been able to reproduce the issue using a new project. With the particular multisound, does it still playback as mono after adding a new stereo sound to its playlist?

I’ve managed to fix it and I think I know what the problem was - I replaced some mono wav files with new stereo ones with the same name after they had been added to the Fmod project. I’m guessing the meta files for these sounds still recognised them as mono. Where the waveform preview is it was displaying the text ‘1 Channel’ even though it was a stereo file. I fixed this by deleting the sounds and re-importing them into the project.


I see. This is a known workflow issue where if an audio asset is replaced outside of Studio, you would need to refresh the channel count and length in Studio via the “Refresh” context menu option in the Asset view. We are looking at improving that workflow.