Music is distorting when placed into the timeline, but it's fine when previewing


(Hayden Davenport) #1

Anyone know why this is happening? I bounced out the audio with -1.0db headroom. It sounds nice and loud outside of FMOD and within the preview in the Audio Bin, but when I actually put it in the timeline of an event, it is heavily distorted at the louder parts.

Thanks!


(Joseph Harvey) #2

What effects are on the tracks of your event? And what are the volume settings of all the tracks of your event and the buses it routed into in the mixer? What are the property values of the sound module? Does your event feature any automation or modulation?


(Hayden Davenport) #3

It’s a new event, so everything should be default, right? It’s the only track in the event right now


(JB) #4

Are you routing your event to a mixer channel? Open up the mixer and see what your master bus output is, if it’s clipping, just lower the master bus or remove and effects it has on it.

Control+2 to bring up the mixer window.


(Hayden Davenport) #5

Here’s a picture of the mixer at its peak volume when the track is playing. Also I checked another track I have in this project, and its peak volume was at almost the exact same level with no distortion at all. Hmm… Any ideas?


(Joseph Harvey) #6

JB’s advice here is good. Since only this one event is affected, there must be some difference between this event and the other events in your project. Check the signal chains of each track and bus in the deck.

One particular thing to look out for is sends on the event’s tracks. If there’s an active send to the reverb return bus (for example) it could be the cause of what you’re hearing.


(JB) #7

Well, check the deck on the master bus of the event as well. Look for if there are any limits or compressors active or volume knobs turned up or down in the event. There are 4 places with volume control, the module, the track, the master track bus and then the master channel or any other channels you route to… Also, go into the assets tab and check your compression settings to the song… The way it’s getting down compressed could be causing this. So check your encoding settings on the .wav file as well.

Make sure there are no mono signal paths you’re going through, make sure the event is “2D” or 3D w/proper speaker splits. Make sure there’s no specialization settings on the master event channel as well…

That’s all I got, unless I was able to poke around in the session or actually test the track myself…


(Hayden Davenport) #8

Ah! The master bus had a limiter on the Deck. The input was turned up to 1db and the ceiling was at -3.5db. It was the ceiling that was causing it to distort. Why though? That seems really weird… The ceiling should just be making sure the track doesn’t go past a certain volume, right?

I’ll ask the others working on the project if they know about the limiter. I wonder if there’s a workaround? They might need the limiter settings where they are currently…


(JB) #9

Ha! I thought so! Well, you’re getting into Limiter/Compressor theory now. If you’re interested… http://www.soundonsound.com/techniques/compression-made-easy

It’s a long article, but it should be able to explain why you’re getting distortion from the limiter.


(Hayden Davenport) #10

Thank you! I can guarantee you that I will be reading that entire article (maybe more than once). Compression continually mystifies me and I’m tired of not understanding it, lol


(Hayden Davenport) #11

Hey, actually, I was wondering if you had a bit of advice because this article doesn’t seem to be answering a question I have. So… when dealing with layered, mastered tracks, how do you make sure they don’t distort when played together? A common problem I’m having is that I master like 4 tracks together and they sound good. But then I bounce them out separately and when I play them together they are way too loud. How can I get around this?


(JB) #12

Use a spectral analyzer on the master to see what frequencies you might be building up.

When you bounce them out separately, all of the compression, limiters or any other mastering type stuff gets applied to the SINGLE track. Essentially making that one track bigger and fuller, but not taking into consideration what the other tracks are doing.

Whereas, when they are all together, your compression is maximizing the sum of all parts into 1. Reducing frequencies in other areas to make room for the whole track.

There could be lots of things going on… if you have a multiband compressor on, you could be compressing certain frequencies MORE because there is a lack of the other tracks. So what might be going on, is you’re compressing the same frequency on all of your individual stems, then when played together later, that frequency ends up having a huge boost.

Edit: Oh yeah… to get around it. JUST TURN THEM ALL DOWN! Or look at what frequencies are building up and scoop them out. Or just address the issue on your master channel when bouncing…


(Hayden Davenport) #13

Thank you! :slight_smile: I think probably turning them down is the best solution here. I’m going to talk to the team and ask them if there is room to turn everything down. I think I got too caught up in worry about things being too quiet that I went too far in the opposite direction… lol