No audio in Unity project after updating from Fmod Studio 1.10 to 2.00.09

Hey all, I’m Audio Lead on a project which recently updated our Fmod studio project and since the update to 2.00.09 from 1.10, for some reason I get no audio when launching the project in Unity 2019.3.1. I can preview fmod events and output audio in the game engine itself, but nothing when I launch the game.

It seems to be local to my machine because no one else on the team has reported the issue. Several of the errors I’m getting in unity seem to be related to Unity being unable to find the Fmod banks in the Builds folder and complications copying the fmod banks into the streaming assets folder. Attached is a screenshot of the errors.

The locations it mentions are the same locations we used in previous Fmod versions, and the bank files are still there.

I’ve tried a total reimport of the Unity project and have experimented with building the banks to different locations - nothing has worked as of yet. Tried a re-install of Fmod as well. Totally stumped now.

Any help would be VERY appreciated.

Thanks in advance!!

You mentioned upgrading from FMOD Studio version 1.10 to 2.00.09. Have you also updated the version of the FMOD Unity integration you’re using to match both the version of Unity you have installed and the version of FMOD Studio you’re using to build the banks? If it only matches one of those version, that could explain the problems you’re having.

Have you checked that the location your Unity project expects to find the banks in hasn’t changed?