Could not load Bank Fmod/Unity

Greetings, dear fellow fmodders!
I work on a new project on PC in Unity 2021.3.8f1 and Fmod 2.02.05. I also tried 2.02.07 and result is the same.
When opening the project for the very first time once Unity is loaded Fmod is not able to find the banks. If stop the Unity editor and try to play again the issue is gone and everything is working fine. Here you can see the log:

I tried refreshing the banks, reintegrating fmod and installing it again 2 times in a row but the issue stays. One of my colleges is working on MAC and he doesn’t have this issue. What can you recommend us to do?

Hi,

The problem may be loading the FMOD Banks from your streaming assets folder. A solution could be loading the Banks from a different folder. That can be found in the folder where your FMOD Studio project is located. E.g. Project Directory -> Build -> Desktop. Or you could set the location of the built Banks from FMOD Studio -> Edit -> Preferences -> Build -> Build -> Banks output directory:

Load in the Banks from this location and it should solve the problem.

Hope this helps!

Hello! I changed the folder in the “built banks output folder” and the result is the same. Mistake remained

Could I get a screen grab of your FMOD settings inside Unity? Found on the Unity toolbar under FMOD -> Edit settings it should look like this in the inspector:
image

Yeah, sure! Check it out here please

And just to double-check. Are the banks contained in the same folder as the Studio Project? e.g. Asssets/Source/Content/Fmod/FmodPR/Build/(target platform) ?

Exactly, the banks are there!

Unfortunately, I am not able to repro the issue.

Is it possible for you to DM me a copy of the Unity and FMOD project so I can try it on my end?

I need to ask my colleges, i work under NDA so i need to figure this out

1 Like