Occlusion not working


#1

Hi,

I previously posted a question about why the sound occlusion wasn’t working, and it seems it was because there were some changes and eventually fixes on the latest version but now there’s another issue.

To make this work I had to do this:

According to the API documentation for UE4, setting the Occlusion property and adding on the master the LPF should be enough, but instead I had to do this work around. Now the problem is that I tested that on a level in which I have a little room, I placed the event so whenever I go out the room, the occlusion performs as expected like shown in the image below:

This test works but, when I used, the same event on the actual level, there are no collisions between the character and the event and I use the same setting as you can see in the image of the test map, the occlusion starts to work immediately cutting the frequencies to whichever value I set. This is how it looks on the actual level:

I changed the options on the Occlusion Trace Channel to Camera, Character and the default which is Visibility, the one used on the test map, none of them worked, they did the same. I’ll really appreciate the help you guys can provide on this because I don’t know if I’m missing something, I didn’t understand the way it should work or what I’m doing wrong.


#2

Currently the integration requires either one of two setups:

  • Adding an Occlusion parameter, which you can use to automate any part of the Event yourself.
  • Adding the Occlusion:1 property, this will allow the volume to be controlled by the game.

Note for a low-pass to be applied by the integration, you have to add either a low-pass, Three EQ or Multiband EQ DSP to the master track of the event.

If you have both methods set up, you may see some strange behavior depending on what the Occlusion parameter is automating.

It sounds like there may be something interfering with the line trace for determining whether the Event is occluded or not.

Have you tried making a LineTraceByChannel test?


#3

Thanks Cameron for the reply. I found out what was the problem and yeah, it was because the mesh collisions where wrong and they were fixed, as for the Occlusion I changed it to the property with the low-pass on the master channel because again, the problem was the collisions.

Thanks again for the reply and if something comes up, I’ll let you guys know