Event Occlusion Not Working


#1

Hi guys,

I’m having an issue with the occlusion property. I’ve tried the methods suggested on the API documentation (via parameter or via properties on the event) and it just doesn’t work. If I set the volume to 0 on the UE Occlusion Settings it simply doesn’t sound and if I change the value it works like the volume but without any interpolation and the LPF doesn’t work at all, I tried with automation, without it and still, no change. I don’t know if I’m missing something or what else can be happening.

Currently I’m using UE 4.20 and FMOD 1.10.09, I can’t update the engine and checking the log about the added features and fixes on FMOD it doesn’t mention anything about a fix in the Occlusion for the FMOD Studio neither on 1.10.09 nor in 1.10.10.

If you guys can help me out finding out what the problem might be, I’ll be grateful.


#2

There have been some fixes in 1.10.10 regarding the UE4 Occlusion:
https://fmod.com/resources/documentation-api?page=content/generated/common/revision.html


#3

Thank you for your replay, I got the last update yesterday but I couldn’t make any testing on that, I’ll check that out. I’ll keep you guys posted on how that goes.

Thanks again.