FMOD Event's Occlusion not working in Unreal Project


I’m having an issue in which for some reason even tho in the Details panel Occlusion Details are enabled, occlusion is not working on a particular project. Before I explain the issue in detail and what I have done so far, a bit of a background on what have been done I think it might be useful so:

  1. FMOD plugins are set correctly within the project just like the documentation says (otherwise I wouldn’t be able to use it in the first place). Said plugins include the Distance Filter and Gain dlls.

  2. I set the Occlusion on the events I need it just like the API documentation says in the integration with UE4 section. The method I used was by setting the property (Occlusion:1) and the effect which is the LPF in the master track of each event.

  3. The versions I’m using for both pieces for software are UE4 v4.20.3 and FMOD Studio Tool 1.10.10

Now the issue is that the project is somehow ignoring the occlusion that I enabled on my events and because of that I did several tests to check what was going on, here’s what I did:

  1. I made a blank project of both the engine and FMOD, used a particular event from the original FMOD project and set the parameters, again, like the documentation says (property “Occlusion:1” and setting the LPF effect on the master track). Then I tried the event and the occlusion worked.

  2. For this one I simply built the assets of the main FMOD project into the engine test project and took the same event that with the same properties and parameters I used for the FMOD test project, enabled the occlusion in the engine and, again, occlusion worked.

  3. I went back to the main engine project with the main FMOD project but I used the other option for the occlusion to be enabled which is by creating a parameter named Occlusion, etc. and, neither the property nor the parameter approached worked.

  4. Deleted the Distance Filter from both events (on the main and test FMOD projects) and occlusion didn’t work on the engine main project but was working on the test projects.

  5. Made the build from the FMOD test project to the main engine project which has just this event with all set and the occlusion didn’t worked.

I don’t know if I’m missing something here but I have checked everything first in the FMOD and then into the engine and I can’t find any clue of what’s going on. As a last test I made another engine project different setup (FPS Project, the first one was a Third person because that’s the layout we’re currently using on the main), made the build of the main FMOD project into the new engine test project and occlusion works.

I’m running out of options, don’t know where to look or go and check, if you guys can give me a hand on this issue I’ll be forever grateful. As a side note, the listener’s position has been change on the main project to match that of the character but I tried with the default because at first I thought it was that was the problem but no, same thing. Again, any help you can provide, will be more than welcome.


I kinda solved the problem I was having by replacing the plugin folder. It seems that at some point the file within that folder got corrupted or something and for some reason the occlusion was the only affected by that so, I guess the problem is solved for now.