Oculus Spatializer plugin / FMOD Studio / No sound output in Unreal

Howdy - Posted this over at the Oculus forums but I figured it would be good to post here too:

I’ve installed the Oculus Spatializer to my FMOD Studio and it shows up fine in the program. I’ve dropped the Oculus Spatializer onto my event’s master track. When I play events within FMOD, everything works/sounds fine. When I build and drop in an audio event in Unreal, I hear nothing. I’ve tried replacing the Oculus Spatializer with the FMOD 3D Panner and the sound works fine in Unreal.

I’m running Unreal 4.17.2, FMOD Studio 1.09.04, and Oculus Audio SDK 1.1.0. I’m on Windows 10.

I’ve tried setting the event to mono, setting the FMOD project preferences under ‘Build’ to be stereo output, and I’ve changed the FMOD preferences within Unreal to be stereo. Nothing has any effect so far. Any ideas of how to fix this? Thanks!

EDIT: It seemed to be working for a bit after turning on the Oculus Spatializer plugin within Unreal but broke again.

Make sure you have added the plugin to the FMOD Settings:

1 Like

I hadn’t added the plugin to the FMOD settings. Followed the instructions from your link, however I do not have a FMODStudio/Binaries/Platform directory. I do have C:/Program Files/FMOD SoundSystem/FMOD Studio 1.09.04/plugins directory, so I added the plugins.txt file there (the Oculus plugin is located there as well).

Unfortunately I’m still not hearing anything in Unreal when I play in the editor. I do hear the sound if I click the Sound Event and press Play in the inspector.

Here are some screenshots of my settings in Unreal and FMOD Studio:

Thanks, Cameron.

The directory “FMODStudio/Binaries/Platform” is in the UE4 integration, either in the Engine or Project. The Oculus plugin and the text file both need to go into the integration along side the fmod64.dll and fmodstudio64.dll.

1 Like

Ah, of course. That did the trick! Thanks so much, Cameron. I’ll post the solution on the Oculus Forums as well.