UE4 no sound being produced

I’m trying to get my fmod events to validate in UE4, but where I previously just used the built in settings, I’m now using the oculus spatializer for my events in fmod. Now when I attempt to validate I receive this message:

The banks require the following plugins, but no plugin filenames are listed in the settings:
Oculus Spatializer

My filepath for my plugin is:
D:\Program Files\FMOD Studio 1.10.07\plugins\OculusPlugins\OculusSpatializerFMOD.dll

UPDATE

I realized that the FMODStudio file was not in my Epic plugins file, so now that validates. Though I am still not hearing any sound when I test on though the desktop, oculus rift or oculus go.

My first thought would be that you may be missing the FMODStudio/Binaries/PlatformName/plugins.txt file, which is used to copy plugins over for deployment.

Make sure you have followed all the steps here:
https://fmod.com/resources/documentation-api?page=content/generated/engine_ue4/plugins.html#/

I’m not getting Oculus spatialiser linking between FMOD and UE4 on Win10.
I have regular (non-Oculus) 3D sound working fine through Rift S.

As instructed here How to Use the Oculus Spatializer in FMOD Studio: Unreal | Oculus Developers I have my OculusSpatializerFMOD.dll (with text file ‘OculusSpatializerFMOD’) sat next to my fmod.dll files in UE4.26 > Engine > Plugins > FMODStudio > Binaries > Win64 but the OculusSpatializerFMOD doesn’t appear as per this image:
Image 1

In UE4 the Oculus-Spatialized event sometimes appears as ‘3D - False’ in details, other times ‘True’ with 0 min and max, not sure where it’s getting 0 from.

Quick video demo’ing my test:

Other stuff I’ve tried:

guide from - Use the Oculus Spatializer for Unreal Engine | Oculus Developers

guide from - Set Up the Oculus Spatializer Plugin (OSP) for FMOD: Unity | Oculus Developers (no idea where mysterious 'Oculus Spatializer folder > AudioSDK\Plugins\FMOD\x64 folder is, i assume it’s same x64 folder from the download ZIP in ‘\ovr_audio_spatializer_fmod’ folder)

in FMOD > Oculus plugin instead of spatializer on each event master track, mono in, stereo out
mixer master bus stereo out (tried both stereo and 5.1 in) and have Oculus Spatial Reverb

in UE4 > Platforms > Win > Audio > Spatialization and Reverb Plugin > Oculus Audio, and Plugins > Oculus Audio > enable Late Reverberation, Plugins > FMOD Studio > Output Format Stereo

any help much appreciated, thanks.

You need to manually enter the plugin name (OculusSpatializerFMOD) into the ‘Plugin Files’ list.

The Oculus settings you are using in UE4 don’t actually interact with FMOD, that is only used if you are using Oculus through the built in UE4 audio.

Thanks Cameron, that didn’t occur to me.

The Oculus Spatial Reverb is now glitching in UE4 when I have Reflections turned on, which is a legacy problem it seems. I could turn off Reflections but that might defeat the purpose?

I’m left wondering if there’s any point using the Oculus Spatializer over FMODs which works fine. I guess the difference is that the Oculus one is targeting each ear slightly differently with HRTF which gives a slightly more natural feel but I don’t think the average user will notice this.

It really depends on the project and what you want to achieve, there are a number of different paths you can take: FMOD - White Papers | Spatial Audio (spatial audio).

thanks,

I have decided to use the Oculus plugin with no reflections just reverb/HRTF, adding a touch of IR as well from FMOD convolution reverb.

many thanks for your support Cameron

1 Like