Resonance Audio Soundfield Not Panning Correctly

Hi all, I just have a few questions…

So first, I’m using FMODUnity; I’ve followed along with the docs and got everything working correctly, at least on the Resonance Audio Source plugin. I’ve also successfully made an ambisonic file from Reaper. I’m taking mono and stereo recordings and sending them through ATK FOA Encode Planewave → Ambi Converter (Noise Makers), in that order. When I monitor that chain with ResonanceAudioMonitor in Reaper, panning inside of the ATK FOA plugin works FLAWLESSLY. When I render, I take off the AudioMonitor plugin and just render to a 4-channel wav.

When I import that file into FMOD, the panning does not work all of the sudden. I’m very sure that my file is in the WYZX format - the Ambi Converter plugin confirms this. My sound should be all W and X, front facing omni, but inside FMOD, it looks like it’s all Y and X, the second and fourth meters are what move, instead of the first and fourth in Reaper. Either way, my audio track goes to the master track with the Soundfield plugin on it, and then that goes to the Master Buss with the Listener on it.

I’m really not sure what I’m doing wrong - it’s so close that it’s teasing me, but I’ve tried so many different options that I’m just frustrated. Thanks for the help (:

What metering channel order do you have selected in the “Audio” tab of FMOD Studio’s preferences window? FMOD Studio uses Positional order by default, but Reaper defaults to Standard order, meaning that unless you change the metering channel order, your meters will be displayed in a different order.