Reverb as a parameter in UE4


I can’t seem to get this working. I have a UE4 BP that triggers reverb when a collision box is entered.

Every Tick, UE4 checks to see if the player is inside the collision space and if so calculates the distance between the player and the collision box’s centre. This is then converted very basically into a figure between roughly 0 and 100, and that figure is then kicked to FMOD to set a parameter called TRM (Temple Reverb Main).

In FMOD, I have an Even set up with an Audio track; it has a reverb plugin, with automation attached to the Reverb Time. Under the TRM parameter, Reverb Time increases approaching 0 (so that it is is effectively 0 Reverb Time at 100+ values).

The parameter doesn’t seem to be responding to the UE4 prompt, even when I override and enter manual entries of 0 and 100.

It’s probably a very simple thing I’m not seeing here! Hopefully someone can shed some light :slight_smile:




FMOD 1.06.10

From the looks of it, I’d say you have a valid setup from the UE4 side of things. A couple of things to check for:

  1. What’s playing in the Footsteps_MarbleX event on its timeline? Keep in mind that the reverb effect you’ve added here will only affect sounds playing on “Audio 1” of this event (it won’t affect other sounds globally). Is this your intention? Are you able to hear this in the tool when you play the event and move through the TRM values? (As an aside, while this approach should work fine, for performance reasons we typically advise that the event’s signal is sent from the master of each event to a global return bus containing the reverb effect. This is the default setup for new projects.)

  2. If you think that the event is setup correctly, the next step would be to check that the parameter values are actually coming through. You can track the event’s TRM parameter using the profiler. See this video for more details about how to do this: