Scatterer instruments very quiet

Every 3D event using a scatterer instrument plays fine in Studio but once in Unity the scatterer plays very quietly. I’ve tried setting the min / max distance to zero, removing the attenuation object on the listener and changing from 5.1 to stero; nothing has any effect. Non-scatterer instruments in the same events play at correct volume.

I note this thread from early last year stating it was a bug - has this not been fixed yet? Scatterer instrument quiet - #12 by tristanjl

I’m using v2.02.29.


So, FMOD / Unity implimentation is full of bugs, devs want a minimum of 2k cash for an indie (when a full on pro DAW costs 10% of that) and to boot… there’s no forum support after a week regarding a bug that’s been known about for over a year?

Lost a customer here, bye bye!

Apologies for not meeting your expectations here, our support team endeavor to respond to all questions asked on our forums within one week. All posts are ticketed and tracked internally to ensure they aren’t lost, but they are prioritized considering that forum support is our free tier, and they must also provide email support for developers who have licensed FMOD.

The forum post you linked was initially flagged as a bug by one of our support staff (Richard), once investigated by one of our developers (Tristan) he determined that the issue was due to the Event being 3D and it not having its 3D position set at runtime. The ticket was closed at this point as a misunderstanding rather than any discovered bug.

Regarding your described issue, Jeffrey raised an internal ticket yesterday for the dev team to investigate further having been able to observe some differences between Studio and Unity playback. I’ve reviewed that ticket and noticed the main cause of difference being due to a misconfigured Unity project.

With FMOD Studio, Edit → Preferences → Build, for the desired platform (let’s say Desktop) the surround speaker mode chosen (let’s say Surround 5.1) needs to match the FMOD Unity Settings → Platform Specific → desired platform (or editor) → Project Platform settings. This is important because the scatterer will always produce output that matches the configured speaker mode, if Studio and Unity do not agree in this regard, there will be audible differences.

Aside from that discrepancy, we’ve found no other significant differences in output audibility. If you are still interested in pursuing this issue, we’d happily take a look at your Studio and Unity projects so we can identify the cause of the differences you are seeing.