Scatterer instrument quiet

Hey, I’m experiencing weird behaviour from scatterer instruments that I’m using in my ambient events in our upcoming multiplatform RPG game. I have no idea what is going on.

I’m using several stereo loops combined with scatterer instruments to create 2D ambiences. While all stereo loops in my events have the same volume in Fmod Studio and in Unreal Engine, scatterer instruments are way quiter when playtesting in Unreal and I can’t seem to find out why. To complicate things even more - the volume of scatterer instruments is the same in Fmod studio and when previewing the Fmod event in UE’s content browser. However when I’m playtesting, then the instrument’s volume drops significantly to the point, that sometimes it’s not audible at all.

Here’s an example - there’s a stereo loop for volume reference and a scatterer instrument with wooden hit sounds (that has a distance set 1-2, replaying each 7-8 seconds). First auditioned in Fmod studio and then ingame in Unreal. I’m attaching a picture from Sound Forge as well, it’s clearly seen that the hits are very subtle in the second half (Unreal engine).
(the file is there for 1 week, I can send it again if needed).

Does anyone know what’s going on and how to fix it? If I understand the scatter distance correctly, it means a distance from emitter, which in a case of a 2D sound (like this one) is where the listener is. However if the range is only 1-2, then there really should not be such an attenuation… When I set distance to 0, it works the same in Fmod and Unreal.

We’re using Fmod 2.00.11 and UE 4.25.


Maybe the scattered event is routed towards a bus in the mixer, which has its volume lowered?
Have you checked the event in the FMOD Studio sandbox?

The event nor tracks with scattered instruments are affected by mixer’s volume. As I said, if I set the distance to 0, then it plays the same in Fmod as in Unreal.
When I put the 2D event onto listener in sandbox, then it works just like when previewing the event in the event editor. No problems.

Do you have a spatializer on the event track or master track? (obviously, you shouldn’t)

No I don’t. That’s why I am specifying that it’s a 2D event. :slight_smile:

Oh, but a 2D event could easily become 3D after a missclick :wink:
Maybe could you share a copy of your project with only the event that causes problems.

Well the problem is in any 2D event, even in the one that I just created for demonstration and put in the link. That means around fifty 2D events in our game. I really doubt the problem is in those events, I think it’s in Fmod-UE integration.

In fact, now that our dev sent me the last build of the game, I found out we have the same problem as you: the scattered instrument is way quieter than when testing in the sandbox. We are using FMOD API.

Interesting… Maybe more people have it but they just did not notice.

This does appear to be a bug. I’m not sure what is happening, but we will look into fixing it for a future update. In the meantime, please connect to your game via Live Update and make some volume boosting adjustments to your scatterer instrument events for them to match what you hear in the FMOD Studio project.

Thank you so much, if the fix would arrive in 2.00.16 (or 2.00.17 at the latest), that would be best. (We will not transfer to Fmod 2.01 for sure). Thank you!

Hi KeyJay,

FMOD doesn’t support 2D distance scattering, only 3D. When you set the distance to 0, distance scattering is disabled and the scatterer will play in 2D (as it sounds like you have noticed).

When you set a scatter distance, the scattering will occur from whatever is scattering. Depending on how things are setup in your game, this could be a long way from the listener.

To address this, you will either have to position the scatterer on the listener or disable distance scattering.

Hi, I just want to say that we didn’t do anything in terms of how ambients are played, but we switched to UE 4.26 and Fmod 2.01.10 and the problem is gone. :man_shrugging: :smiley: Thanks for your reply anyway.