Sound Quality Loss

When I import mp3 files into FMOD, it looses some of the high end.
The issue happens everywhere in the project; asset browser, event timeline, and also when building the bank and implementing it into unity.
I’ve tried to tweak the build encoding settings: sample rate, quality, encoding format… and nothing seems to work.

Here is a video with a demonstration of the problem. On the first track we have exacly what i hear on FMOD (recorded from a new project), and in the second track the original sound, what i hear when i play it on Finder or anywhere.

Hope you can help me.

First of all, why are you importing your assets in mp3? Secondly, maybe did you forgot an effect on one element of the bus routing chain?
However, on my phone’s speakers, I don’t hear the difference.

I import in mp3 for saving space on my hard drive, but I’ve also tried with a wav file and it looses quality in the same way.
The thing is that it sounds diferent the file listened from itunes (or any other media player) compared to listened in the FMOD browser, I guess that this shouldn’t happen in theory.

I suggest to listen it with better quality, the original one is very rich and bright, and the other became muffled.

Update: I’ve tried with another computer, same results.

Whilst I can’t tell the difference through the YouTube video (likely due to YouTube’s compressions) I can hazard a guess that this is likely due to resampling when importing the asset into FMOD Studio. Some sounds and their harmonics react to linear resampling in unexpected ways but switching it to cubic resampling may help.

You are able to set the resampler to use cubic resampling by setting it before initializing FMOD in your game.

memset(&settings, 0, sizeof(settings));
settings.cbSize = sizeof(settings);
settings.resamplerMethod = FMOD_DSP_RESAMPLER_CUBIC;

This may cause some performance hits. It really depends on how much of an issue this change in sound is.

That could be the thing, I will definitely try it out when I get the chance.

Many thanks!

Finally I found the issue.
The real problem was that on my build I had the surround speaker mode on Stereo instead of Surround 5.1.
All the sounds in the game I’m working on are 2D sounds, so I changed this setting thinking that it was the correct configuration.