Audio File Quality Loss on Import

Would anyone be able to shed some light on an issue I am having at the moment? Would be greatly appreciated :slight_smile:
I have found that upon importing my audio files into FMOD I am getting a significant reduction in audio quality. I am losing quite a bit of top end and bass as well as a substantially impaired stereo field - basically just a significant drop in quality. Here is a link to a video comparison where I just drop an audio file straight into a fresh project.

Audio Device is an NI Komplete Audio 6.
I’m using 24bit/44.1khz WAV and have also tried with a 24bit/48khz WAV with same results.
All tracks checked to have no 3D panners, no effects and set to stereo config.
Master Bus set to stereo as well as trying all other values.
I have also tried importing by placing in audio bin first as well as just dropping into an event but all same results.
The WAV also auditions in the Audio Bin as poorly as it does in the event.
I have tried multiple audio files and I am getting exactly the same results across the board.

I cannot see anything that should be making this much of a drastic difference. So I’m thinking either I am missing some hidden setting or am not doing something correctly?

Would love some help on this because I can’t move forwards without addressing this.

1 Like

How does the audio file sound when auditioned in the assets browser? If it sounds the same as it does when played outside of Studio, that suggests the issue must be in one of the tracks or buses downstream of the instrument.

Are you able to send us a copy of the affected file so that we can try and reproduce and investigate the issue here?

Hi Joseph,

Thanks for your response.
Just checked and the file still sounds of poorer quality in the Asset Browser. It’s not just a single file, it’s any file I import into FMOD. I can send the small test project I’m using through or just the file in my video?

Since the issue occurs in new projects with no special features, the audio file should theoretically be enough.

No problems at all. How would you like me to send it through?

The best method is to upload the file to a file upload service such as Dropbox, and then send us a link.

As an alternative, you could attach the file to an e-mail, and send it to along with a link to this thread.

Hi James.h!

Are you sure that it’s not just the difference in loudness levels? At least this is what I hear from your screencast. It’s common to have the low and top perceived as less when lowering volume, and I can hear that your audio file player and Fmod have a difference in volume. Also, this can contribute to the loss of your binaural perception and change of the stereo image, as localization of sounds happen in the higher range, which diminishes with lower volume.

If I’m mistaken, let me know please.

If you’re not sure, you can do the following to check:

Record the audio from your operating system with some tool like the one you use for screencasts.
Record both players, playing the same audio from the start.
Any audio file will do, but best to have something easy to align later.
Import both of them in two different tracks in your DAW.
Reverse the phase in one of the two. It doesn’t matter which.
Render the sum of those two files and import it on a third channel.
If the waveform is similar to the rest of the files and just lower in volume, then you are just hearing lowering of volume in your setup and not other kind of signal degradation.

Hope you find a solution anyway.


Thanks for e-mailing your file to us. We tried playing it through FMOD Studio and comparing the output to the original file. As far as we could tell, there was no discernible loss of quality when playing through FMOD Studio. Frequency spectrum analysis of audio captured from FMOD Studio did reveal some very small differences, but nothing perceptible to humans.

Have you tried tweaking the volume, as Panagiotis_Kouvelis suggested? It’s possible that your operating system is using different settings for FMOD Studio compared to your other media player applications.

1 Like

Hi Joseph,

Thanks for getting back to me and taking a look at the file.

I find no discrepancies across any of my players; Logic Pro X, Audacity, Ableton, Mac Player etc etc yet as soon as my audio goes into FMOD the issue arises. FMOD is set to use the same sound card they too are using, everything runs through my interface so I can’t see how there would be an issue there.

Would you be able to send me the audio you captured from your FMOD so I can compare it to mine?

To me there is a clear visual difference in the waveforms not only audible. The shape and transients are different and I can assure you it is not a volume difference I am hearing (I have run various comparisons to make sure this is not the case including the one below) So if your output file is the same as my original and not the same as my FMOD capture then I know I have an issue.


1 Like

I have sent you the file via e-mail.

Given that you’re seeing the problem even when auditioning in the assets browser, try checking the encoding settings set for each of your project’s target platforms. You can find them in the “Build” tab of the preferences dialog. These settings influence most auditioning in Studio, including the auditioning of assets in the assets browser, while “audition with compression” mode is enabled. You could also try toggling audition with compression mode by clicking the “Compress” toggle button in the asset preview at the bottom of the assets browser.

Other than that, I know of no setting or property in FMOD Studio that would cause audio files auditioned through the assets browser to sound different. I therefore suspect that this issue is caused by some operating system or driver setting, or by some third-party application that affects the audio output of other applications. If you have any software or drivers that automatically process the audio output of certain applications (for example, software that reduces noise or feedback in games with voice chat, or accessibility software for the hearing impaired), try disabling that software or changing its settings, and see if it makes any difference.

If possible, try installing FMOD Studio on other machines and auditioning your audio files through FMOD Studio on those machines. If the files play without obvious loss in quality, check for differences in what software is installed on both machines; if they still exhibit a loss of quality, look for similarities. Either way, you’ll hopefully be able to narrow down possible causes of this issue.

Hello FMOD folks. I’m having an issue that may be similar. The difference is when I preview a sound in my asset window it sounds good and normal and the same as how I bounced it from Logic. Once I drag that asset into the event timeline it sounds terrible and very muddy. It also plays back in the game engine as muddy sounding. I checked the build settings, encode settings, which someone suggested to me and there are PCM 44.1k (original files are 16/44.1). It sounds like an eq is being applied. Any ideas on how to fix this?

If it sounds fine in the assets browser, the cause of the issue must be downstream. Are there any effects on the audio track on which the instrument is placed, or on the master track? What about on the group bus into which the event is routed, and the project’s master bus? (If it’s a 3D event, there should be a spatializer effect on the master track, at the very least.)

Ah. I found it. I was using a template from someone and there was a low pass filter that I didn’t realize was on a couple events. Thank you!

Cool @edvarga, nice to hear you squashed that bug out of your project! :slight_smile: