Spatialization doesn't seem to be working on Gear VR


(Alex Zubov) #1

Finally got to test Version 1.08.12 for UE4.

Sound now works on Android, but it doesn’t seem like sounds get spatialized at all. I can determine whether I am getting away or closer to the sound source, but I can’t determine the direction is coming from.

I stood in the game in such a way that sound source was to the right from me and I removed my earbuds alternating ears. Sounded equally strong in both ears.

Spatialization doesn’t seem to work in the FMOD Studio either. When I play sound and mess with the 3D Preview sphere, sound doesn’t change “direction”. I am using Oculus Spatializer in FMOD Studio.

Another issue I noticed is that when I started the game, sound was almost at minimum volume. When I pressed Volume Up on Gear VR, sound volume indicator showed 3/4 high volume bar. As soon as I pressed Volume Up, sound got set to proper volume.

UE 4.13.0, Oculus Audio SDK 1.04 FMOD plugin.


(Brett Paterson) #2

Hi Alex,
Thanks for describing your issue . I would like to see if you can confirm if the standard FMOD 3D Panner works in your app / hardware setup. If it does, but the oculus plugin doesnt, it might be worth contacting oculus to see if there is an issue with their plugin.


(Alex Zubov) #3

I bypassed Oculus Spatializer in FMOD Studio and tried 3D Panner and 3D Object Panner.

3D Panner doesn’t do any spatialization. 3D Object Panner does.

I haven’t tried using 3D Object Panner on Android/Gear VR yet.


(Brett Paterson) #4

I would be surprised if the standard 3d panner didn’t do spatialization, unless its not being passed the correct information. I assume you’ve tried the 3d preview in the top right of the FMOD Studio interface and it works? It is only the UE4 side of things that is causing you trouble right now?


(Alex Zubov) #5

Yes, that sphere is what I tried. I am not sure what’s the difference between 3D panner and 3D Object panner.

I deployed to Android/Gear VR using 3D Object panner instead of Oculus Spatializer in FMOD Studio: https://s12.postimg.org/7f69psfiz/fmod_studio_3_DObject_Panner.png

With that I can clearly hear direction from which sound is coming from, but attenuation doesn’t seem to be working - I crossed the level and could clearly hear the sound from another end of the level. Maybe it’s just settings on the spatializer, not sure. Didn’t have all these issues with UE 4.12 :frowning:


(Brett Paterson) #6

The 3D Object panner is for Dolby Atmos panning and other modes that support object panning (like Playstation Morpheus).

You should be using the standard 3d panner. If you simply move the sound around in the 3d preview window it will pan and attenuate. You just have to make sure the min/max is set up correctly and thats about it, there’s not much else to it.

If you load up the fmod examples they all will work this way.


(Alex Zubov) #7

I see. Well, like I said it doesn’t work. It worked in whatever version of FMOD Studio I had prior to UE 4.13 release. I’ll mess with settings more, but it used to work out of the box.


(Alex Zubov) #8

Btw, getting these:

LogFMOD:Warning: e:\jk\workspace\1. Build_UE4_1.8_Libs\studio_api\src\fmod_effect.cpp(189) - Missing DSP plugin ‘OCULUS SPATIALIZER’
LogFMOD:Warning: e:\jk\workspace\1. Build_UE4_1.8_Libs\studio_api\src\fmod_bankmodel.cpp(240) - Creating stub DSP plugin model and continuing.

OCULUS SPATIALIZER is in the FMOD Studio, active, banks are built for all platforms, libovrfmod.so is in the binary folder in the plugin in my UE4 project and XML file is the same as it was in UE 4.12.5


(Brett Paterson) #9

Hi, I was still trying to clarify if you had it working in studio, simply setting up a new event, then panning it in the tool, but you said it didnt work. I’m trying to rule out if the problem exists for you there or in UE4 only, you jumped back to the UE4 side.

If it can’t find the oculus library then you probably havent got the dll placed in the correct location. I’m still trying to clarify about the standard 3d panner though, which is what pretty much every game using FMOD Studio uses.


(Alex Zubov) #10

I tried regular 3D panner on individual sound events inside my scatterer sound and regular 3D panner works fine. However 3D panner doesn’t work on Master channel(?) of scatterer sound.

My sound actor setup in UE4 (I checked what I had in UE 4.12 and I didn’t have Override attenuation set; did the same in 4.13 and also tried using Override Attenuation - no difference in the outcome):

My setup in FMOD Studio (same as I did for 4.12, following Pete’s recommendation here http://www.fmod.org/questions/question/fmod-oculus-spatializer-potential-bug/ ):

To summarize, in 4.13 and latest FMOD UE4 plugins and FMOD Studio I am using identical setup to what I had in in UE 4.12 and corresponding FMOD plugin / FMOD Studio.


(Alex Zubov) #11

I will make another test - having single sound (not scatterer) with 3D panner and another single sound with Oculus Spatializer and see how that works in UE4 on Android.


(Brett Paterson) #12

your video is really blurry at the start, but you’ve got range min set to 5.0 instead of 1.0, so attenuation is going to be 5x further away than the default.


(Alex Zubov) #13

So, I am trying to wrap my head around how to deploy to Android without using Oculus plugin and I don’t see how. Following this: http://www.fmod.org/documentation/#content/generated/engine_ue4/deployment.html and the docs implies usage of Oculus plugin libovrfmod.so

So no matter what I try, if libovrfmod.so is broken, I will not be able to test 3D panner on the device - it will always fail to do spatialization.

How do I deploy to Android without any plugins, using stock FMOD Android support ?


(Brett Paterson) #14

That is an example of how to deploy a plugin. It is not a requirement. Just do not include oculus in your project, and dont do anything to do with the plugin. This plugin is totally optional. If you do have the plugin in your project and dont care about it, or want to test another event , use FMOD_STUDIO_INIT_ALLOW_MISSING_PLUGINS
so you dont get an error.


(Alex Zubov) #15

Alright, I did a test with a single sound event - spatialization (using 3D panner) works in FMOD Studio, in UE4 Editor (PIE) and on Gear VR.

Spatialization (using 3D panner) on Scatterer sound doesn’t work anywhere.

Video (now with sound):


(Brett Paterson) #16

your output of your track is set to mono, that is why you get no panning


(Alex Zubov) #17

Ahh, didn’t even noticed it :frowning: Thanks a bunch!