Streaming Assets Error on Unity WebGL build

I am trying to get started with FMOD for a Unity WebGL game, and I have been testing with the bouncing ball example found here: GitHub - fmod/unity-html5-demo: Demonstration of the correct way to load banks for HTML5 within Unity using the FMOD For Unity integration.

That demo works fine in editor, and works fine when I build and run for WebGL. However, when I upload the build to a website for testing I see the following error when I attempt to load the banks

While tracking down the issue, I get the same error if I just try to print out the Application.streamingAssetsPath value that is used for Platform.GetBankFolder().

How should I be loading in banks for a webgl build? Is there some setting on the website itself I need to change?

Unity version is 2020.3.16f1 and fmod version is 2.02. Unity 2021 also failed in the same way.

I was not able to replicate the issue after uploading the Demo to the web. However, we check some things to ensure the banks are being loaded in.

Check we are using the right source type in the Bank Import settings. Begin by opening the FMOD Settings found under the Unity toolbar → FMOD → Edit Settings. What we want to take note of the source type we have selected. Make sure it is set to Single Platform Build from the drop-down menu.

Then we will want to check the Build Path option is set to the folder containing the banks for the Demo. Which is located at Project Folder/Assets/HTML Demo/Banks.

That is a good place to start when checking if the banks are being loaded in. Have you altered the supplied code in any way? If so there may be a problem there, could you please supply code snippets of any changes you made?

Hope this helps!

I haven’t changed the demo code at all, I was just attempting to get things working online. I will double check the build paths and source type when I have a chance to get back this.

1 Like