Transitions with quantization lag one bar behind

Hi, I am trying to have transitions between two music clips using a parameter condition. I used quantization as I want them to transition on the beats. However, for the second clip, whenever quantization is turned on, it “adds” one bar of silence at the end before going back to the beginning of whatever clip it’s supposed to. In this gif you can see the first clip working as it should, and then the second having that one bar of silence. The clips are almost identical, have the same duration etc.


Why does this happen? How can I fix it? I am baffled by the fact that it works for the first clip, but not for the second, despite it being identical.

It is also worth noting that when I turn off quantization for clip 2, the transition is really weird: When going from clip 1 to clip 2, the transition is instant, despite the fact that clip 1 has quantization on. When going from 2 to 1, the transition happens on the beat even if clip 2 has no quantization. How can this happen? Do I just not understand how quantization works? (I would have included another gif, but I am not allowed, as a new user). And also, with quantization off, clip 2 ends where it should.

I’ve been trying to wrap my head around it for two days now to no avail, so any help would be greatly appreciated!

I’m not able to replicate your problem. How did you configure your parameter conditions on your magnet regions? Which version of FMOD are you using?

Thank you for answering! I have a labeled parameter with two values: Clip 01 and Clip 01 Drums. In the pic you can see it for the first magnet region. I did the same for the second, but with “clip 01 drums” as a parameter condition. When my parameter is set to “Clip 01”, it plays Clip 01, and the same goes for the second clip.
I am using 2.02.03
I am sorry if this is not what you asked, I am very new to FMOD.

You do understand how quantization works, but not magnet regions. Magnet regions are “destinations”. Therefore, the quantization applied to it is for going to this region, not for quitting this region. So the behavior you describe is normal.

I’m surprised in your last screenshot you didn’t set the “offset” to “relative”, since your first video was showing the relative behavior.

That being said, the bar off seems like a bug. I’m not able to reproduce it. You should probably save your event and share it, for FMOD staff to analyse it. Also, try to recreate your event from scratch to see if the bug still occurs.

Thank you, I re-did everything in a new project, and it seems like there is no bar off now, so it may have been a bug.

Maybe did you mess up with the snap. I’m able to reproduce a part of the bug. Something like this (at max zoom):

Alcibiade’s explanation is the most likely one. I suspect that the magnet region exhibiting the “one bar of extra silence” behavior actually ends slightly after the bar does, meaning that the playback position doesn’t hit a quantization point that’s outside the magnet region until it reaches the end of the bar. You can test this by resizing the magnet region at a high zoom level, and seeing what points it snaps to.

1 Like

Yes, that is true, I just tested it. On max zoom, the magnet region was slightly over the last bar. I adjusted it so that it is now before that bar, and the problem is solved, it plays back as it should.
Thank you both very much!

1 Like