UE4 4.13, FMOD 1.08.14 - No audio on Packaged Win64/Win32, but audio is fine in editor and in Packaged Xbox One & PS4


I’ve got UE4.13 installed, with FMOD 1.08.14 (4.13) inside the project plugins folder. I’ve got banks built with FMOD Studio 1.08.14, and have Reloaded Banks using File->Reload Banks in the editor.
In Project->Packaging settings I have FMOD as an “Additional Non-Asset Directories to Package”.
Our file structure is Content->FMOD->Banks/Buses/Desktop etc.

All sounds and sound effects, including volume control (Bus Set Fader Level blueprint node) work perfectly in Editor (Play in Viewport & Play as Standalone modes) and on Xbox One/ PS4 shipping and development builds. The PC versions however have music and only one bank working. All other sounds do not play when they should. Additionally, “Bus Set Fader Level” does not have any effect on the volume of the music audio.

I believe I’ve exhausted all routes of enquiry so far, including:

I’m all out of ideas with getting this working properly, could it be a bank thing?

Could you try enabling verbose logging for FMOD and see if there are any errors/warnings that may help.


Uploaded the log here: https://drive.google.com/open?id=0ByqRJN8UjA_AeWdEakxVQVFDb3M

Nothing looks out of the ordinary.

Everything looks fine in the log, it even says that it is opening all the banks.

You could try manually deleting the banks from the FMOD folder in the project and re-importing them.

Are you able to reproduce this in a new/empty project at all?

I deleted the Content/FMOD/Desktop folder, opened FMODStudio, re-built the Desktop banks and restarted my engine. All sounds imported fine. Packaged build it’s still not working.

A new project was able to play all sounds that are not currently working in our main project.

The next step I would take is deleting the FMODStudio folder in Plugins, then copy in a fresh copy of the integration.

It looks like it has something to do with your main project in particular, since you can get the sounds to work in another project, but without any errors makes it difficult.

Re-installing the plugin hasn’t changed the behaviour we’re seeing either.

It’s definitely a weird one, because on everything except packaged Win builds the audio is perfect. And even when broken it’s only specific groups of sounds like “box movement” or “UI”.

Apparently on PC, FMOD was not initialising properly but on all other platforms it was. It boiled down to a timing issue so we’ve inserted the FMOD constructor into a class derived from UGameInstance:

UGIDefaultBase::UGIDefaultBase(const FObjectInitializer& ObjectInitializer) : UGameInstance(ObjectInitializer)


This has solved the issue.

Glad you got this sorted, I believe this can be caused by the blueprints being serialized from disk before any plugins are loaded.

This is the only post I have found in any way related to my troubles its just unfortunate that the fix for the op does not work in my case. Cameron, if you are correct in your thought of blueprints loaded from disk causing issue, would using the static ConstructorHelpers::FObjectFinder cause the blueprints to be loaded before this solution? I am currently on 4.17 of the engine 1.08.15 of fmod and am experiencing this exact problem where setting either the bus levels or the vca levels is doing nothing, instead of calling the blueprint versions of the SetLevels I even tried finding and setting the vca’s myself using their GUID and the ParseGUID function to look them up, which were both found correctly but changing them did nothing. Will be looking into this further to see what might be causing the problem to persist in our case.

Normally this problem stems from FMOD being called in the level blueprint before the Plugin Module has had sufficient time to load. If you are still having issues I would check the fmod log file, and even enable verbose logging for more information.