FMOD not playing sound in packaged build


I’m at my wit’s end and I hope someone can give me some pointers on this. I’m trying to export a project that uses Unreal 4.12.5 and FMOD 1.08.08, and the audio, which is completely made in fmod runs fine in the editor but not in the packaged build.
I’m on a Win10 64bit machine.


  • I started using
    as a guide and added my FMOD banks folder to “Additional Non-Asset Directories to Package” in Project Settings.
    My FMOD folder is in the content folder of my game.
  • I am also using the oculus spatialisation plugin and thus I added a plugin.txt file to my binary folder (C:\Users\User\Desktop\GameName\Plugins\FMODStudio\Binaries\Win64)
  • I packaged the game for Win64 - development and get no error messages.
  • When opening the game no, I have no sound. I can also not find any of my sound banks in the packaged folders.
  • I came across
    and added all banks manually to my packaged game
    (to C:\Users\User\Desktop\Packaged\WindowsNoEditor\Engine\Content\FMOD\Desktop), still no sound.
  • I found this
    and thus I added all .dll files to
    This includes all .dll files specified in the plugin.txt file as well as the binaries found in
    I even added all .dll files from my fmodstudio installation to the binary/thirdparty section of the packaged game, to no avail.

I’ve been trying these things all day, any help or pointers are appreciated.
Thank you

1 Like

You’ve done the right thing by adding FMOD to the “Additional Non-Asset Directories to Package” setting.

For Oculus (or any other plugin), you’ll need to create a plugins.txt file in the Plugins\FMODStudio\Binaries\Win64\ directory with the following line:


Packaging up plugins is mentioned with a link in that deployment page, but its easy to miss. You should see that plugin file being included in the packaged build by checking the Output Log, look for a line like this:

MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: Adding reference to FMOD plugin: _ProjectPath_\Plugins\FMODStudio\Source\FMODStudio\../../Binaries\Win64\ovrfmod.dll

Once the packaging is complete you should be able to see both FMOD and the Oculus plugin in the following directory:


You won’t see the banks since they’ll be packaged up into the pak file. You mentioned the Development build, that prints a log, so you can look for errors such as failing to find banks, or failing to find and load the Oculus plugin. Look for log messages here:


Lastly, you don’t need to manually copy bank files or FMOD dlls around any more. That should happen automatically for you.



thank you for your quick answer! That was really helpful.
I already had a plugin.txt file so I had the following line in my log already:

MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: Adding reference to FMOD plugin: ProjectPath\Plugins\FMODStudio\Source\FMODStudio…/…/Binaries\Win64\ovrfmod.dll

Looking through the log was the key however, as I noticed I also got

LogFMOD:Warning: c:\jk\workspace\Build__1.8__UE4Libs_Win\studio_api\src\fmod_effect.cpp(189) - Missing DSP plugin ‘OCULUS SPATIALIZER’
LogFMOD:Warning: c:\jk\workspace\Build__1.8__UE4Libs_Win\studio_api\src\fmod_bankmodel.cpp(240) - Creating stub DSP plugin model and continuing.

which led to this solution

So I basically added the ovrfmod.dll to allmost any plugin and binary folder in my project, as well as the fmod studio standalone and the unreal core engine (for good measure).

Packaging it now gives me now fmod related warnings however I still hear no sound .
I solved this by adding the ovrmod.dll and .lib to the packacked project manually, under \Plugins\FMODStudio\Binaries\Win64

Now I got all the sounds, so I’m happy enough for the work-around.
Still strange I have to add the file manually.

Thank you for your help again, you saved me from another day of stagnation.

One thing to be aware of is to make sure you have the same ovrfmod file in the FMODStudio UE4 directory as the Studio plugins directory. If the versions differ then banks exported with one version may not properly play with another version. Perhaps you had a mismatch and in copying have ended up with a consistent version.

1 Like

hi, is ovrfmod still a thing?

can’t see this file anywhere… just curius


The Oculus Spatializer plug-in is a third-party plug-in developed and maintained by Oculus. As such, we at Firelight Tecnologies do not know in any detail how and why it has changed.

If you have questions about this plugin, we recommend you contact its developers through Oculus support.