Unable to load module UE4Editor-FMODStudioEditor.dll' because the file couldn't be loaded by the OS


#1

Hi! When packaging my Unreal C++ project I get the following warnings and error:

================================
UATHelper: Packaging (Windows (64-bit)): LogModuleManager: Warning: ModuleManager: Unable to load module ‘…/Plugins/FMODStudio/Binaries/Win64/UE4Editor-FMODStudioEditor.dll’ because the file couldn’t be loaded by the OS.

PackagingResults: Warning: ModuleManager: Unable to load module ‘…/Plugins/FMODStudio/Binaries/Win64/UE4Editor-FMODStudioEditor.dll’ because the file couldn’t be loaded by the OS.

UATHelper: Packaging (Windows (64-bit)): LogUObjectArray: Warning: Invalid object index 6553701

PackagingResults: Warning: Invalid object index 6553701

UATHelper: Packaging (Windows (64-bit)): LogWindows: Error: begin: stack for UAT
UATHelper: Packaging (Windows (64-bit)): LogWindows: Error: === Critical error: ===
UATHelper: Packaging (Windows (64-bit)): LogWindows: Error:
UATHelper: Packaging (Windows (64-bit)): LogWindows: Error: Assertion failed: GIsHotReload [File:D:\Build++UE4\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectBase.cpp] [Line: 606]

UATHelper: Packaging (Windows (64-bit)): LogWindows: Error: Trying to recreate class ‘AFMODAmbientSound’ outside of hot reload!

================================

Unreal Version: 4.20.3

Thanks in advance!


#2

Anyone? :slight_smile:


#3

I cannot say that error looks familiar.
What version of FMOD are you using?
Have you tried re-importing the FMOD-UE4 integration to make sure nothing is missing?


#4

Hi Cameron, re-importing the integration worked!

Thanks for the help!


#5

Hi again! Unfortunately, this issue keeps coming back.

As a workaround, I have to close the Unreal-editor, rebuild the project in Visual Studio and after that open the Unreal-editor again and package the project. This takes a lot of time.

FMOD Studio: 1.10.05
UE4 Integration: 4.20.3

Thanks in advance!


#6

This should only occur when the integration source code is changed.

How often does this occur?
Does it normally happen after something specific?

Can you test this in a new/empty project to see if it still occurs?


#7

Unfortunately, I don’t have time for that at the moment. It seems to occur in conjunction with “Hot Reload” if I have both Visual Studio and Unreal open at the same time and have compiled my project. As the error says it’s something with Hot Reload:

Those days I only work in Unreal (i.e. Visual Studio is closed and no compiling of code) it seems to work to package the project at any time.