Plugin 'FMODStudio' failed to load because module 'FMODStudioOculus' could not be found.

Hi, I have checked earlier answers for this topic but I didnt found any solution for my problem. I’m trying to package a UE 4 4.8.1 project with FMOD with Oculus plugin. In editor it is working correctly but after packaging it shows the error:
Plugin ‘FMODStudio’ failed to load because module ‘FMODStudioOculus’ could not be found.
What I have tried already was to add binaries for FMOD win32 and win64 to ThirdParty\FMODStudio folder of package(when they are added or not error is the same), the second thing which I tried was to force platform to mobile both in FMOD and project. Third was to add FMOD content folder to Additional NON-Asset Directories to Package in UE4 project settings. Nothing worked. Any help?

Still nothing. I have tried completely new blank project and after packaging I’m getting same error. Anyone? Help?

It sounds like you are doing all the right things. Could you provide a little more info?

  • Do you have a blueprint or code project?
  • Do you have the FMODStudio plugin in the engine folder or the game plugins folder?
  • What OS are you using (e.g. windows 7?)
  • What are you packaging for, Win32 or Win64?

I just tried a refresh blueprint first person project in 4.8.1, and packaged it properly for Win32.

Note that as part of packaging, it should copy the fmod dll files into


If for some reason they aren’t being automatically copied over, you could try manually copying them after the deploy finishes, and see if that fixes it.

Windows 7 64 bit, package to 32 and 64 bit was tested. Blueprint test project (blank created as new from UE4), FMOD plugin is normally used in Unreal/plugins catalogue, but I also tried to put it inside of a project folder before a package. I tried to put dll files in proposed dir (in win32 /64 folders and without them). No more clues… :frowning:

Do either of you have Visual Studio installed?

I have a feeling that the automatic relinking of the blueprint project is failing, but in a way that isn’t producing an error message. Could you try installing the commmunity edition (its free) and see if it starts working?

We don’t have many machines here that don’t have Visual Studio but I can find one and see what happens when building on UE4 without it, just in case that is the issue.

I have VS installed all the time. I tried to reinstall whole Unreal Engine, and installed plugin freshly downloaded from site. No progress- still same error after packaging any project, no matter if it is using FMOD assets or not.

Are you deploying for Development or Shipping? When you deploy, does it create a directory under WindowsNoEditor\Engine\Plugins\FMODStudio\Binaries\Win64 with any dll files?

All types of builds Dev or Shipping(with PAK file creation turned off to see what is passed to the build) creates plugin folder with FMODStudio folder, but there is no binary folder with dlls inside. Still manually adding of the binaries\win64 and binaries\win32 don’t make nay difference, error still appears.

Sorry I still can’t reproduce this. Could you follow up at I would like you to create a new blank blueprint project with FMOD installed in the engine/plugins directory, then package a Win64 development build. If you can email me the output log (viewable from the editor) it might provide some clues about what is going on.

I have the same problem, currently running the latest FMOD Studio/plugin with the latest UE-release from the launcher (4.8.2). Setup properly, doesn’t work. Manually adding the files doesn’t work either, packaging a development build to win64. Tried android and whatnots too.

Seems that UE4 4.8 again has a problem with packaging plugins to projects containing blueprints only. I have resolved my problem by adding empty C++ method to the project. After this during the packaging FMOD binaries were passed to the plugins\FMODstudio\Binaries\Win64 folder. Still I had to add ovrfmod64.dll to this folder as it was not copied automatically and also I had to manually add content\FMOD folder with sound banks (this probably can be also solved by adding FMOD folder in project packaging settings under “Additional NON-Asset Directories”). So, it is working now :slight_smile: . Thanks for the support, probably that clue about Visual Studio turned me to checking this solution.

It is also working in 4.8.2 UE version.

I’ve finally figured out this issue. The FMODStudio.uplugin needs to have a field in order for the project to relink:

“Installed” : true

Our latest release has the updated file, or it can be obtained here:

Note that any plugin that has the field will do. So if you have installed the Substance plugin from the marketplace (which I did for testing), then FMODStudio will start linking properly, even if you don’t use Substance at all in your project.

You will also need the Visual Studio 2013, which can be downloaded for free here:

Note it must be 2013, not 2015. You can tell if you have installed it by choosing New Project and clicking the C++ tab. If UE4 doesn’t find Visual Studio installed, a red warning message will appear prompting you to download it.