Unity 5.6 bitcode not enabled for iOS

Hey there,
I tested FMOD for the first time today in a blank unity project. On iOS I sadly get this error:

‘/Builds/iOS/gitlfs/Libraries/Plugins/iOS/libgvraudio.a(wav.o)’ does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target. for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

Seems like the library file missis bitcode (Which is required by now if I’m not mistaken). It seems like there was this problem some time ago (https://www.fmod.org/questions/question/bitcode-support/), (http://www.fmod.org/questions/question/fmod-issue-with-unity-5-3-2/), but it sounded like it was resolved. Am I missing something?

As for my setup:
MacOs 10.12.4
XCode 8.3.1
Unity 5.6.0f3
FMOD 1.09.04

Any idea how I can fix this?

There are some issues with the GVR plugin for iOS at the moment that we are working with Google to rectify. For now I’d recommend you remove the libgvraudio.a plugin so Unity doesn’t try to link it in.

1 Like

Removing the file fixed it, thanks!
I’m not quite sure why you would include a somewhat broken library file, but anyways good to know that there are no dependencies to the library if it is not used :slight_smile:

Glad to hear that worked, the file got incorrectly cleared by QA, we are hoping to get it sorted out soon. It’s only necessary if you are using the GVR plugins.