Unreal Engine 5.2 not finding FMOD master bank when collaborating with other developer

I am working with a developer who is getting an error that Unreal “Could not find Master.bank” and we have checked everything we can think of. Any help would be great! Below are screenshots of the issue. When looking in the explorer we can see all of the files in the content browser, but they do not show up in Unreal and it fails to import when dragged in.

The way I am sharing the banks is by building the banks to a folder on my computer, then sending him the “Desktop” folder via Google Drive. Let me know if there is a better way to do this!

Errors we are seeing

“Could not find Master.bank”
LogFMOD: Error: Failed to load bank lookup
LogFMOD: Error: Failed to load asset lookup
LogFMOD: Error: Failed to load asset lookup

The plug-in defaults to looking in ‘{MyProject}/Content/FMOD/{Platform}’ directory for banks, it will then generate uassets for those banks in ‘{MyProject}/Content/FMOD/Banks’.

You can also change these settings in Unreal, see https://www.fmod.com/docs/2.03/unreal/settings.html#bank-output-directory.

Hi! Thank you for your response, I tested this on my machine by moving the FMOD folder, then changing the Unreal bank path and it worked. However, it still is not working on the game developers machine. We created a new project with only FMOD in the content browser. Everything works great on my side, but when he puts the banks in the {MyProject}/Content?FMOD/Desktop directory Unreal is still unable to find the master bank.

We noticed when changing the Bank Output Directory that the .bank files don’t show, but not sure if that makes a difference.

Not sure if I mentioned before but I am on a Mac and he is on a PC if that makes a difference!

Please let me know what would be helpful for troubleshooting!

The Bank Output Directory in the FMOD Settings in Unreal refers to the output of FMOD Studio, eg. the default is ‘{ProjectName}/Content/FMOD/’, where it expects to find the different platform folders.

Content Browser Prefix is where the .uassets are generated and accessed in the editor content window.

So if you are using the default settings for both of those, the integration will be looking for: “{ProjectName}/Content/FMOD/Desktop/Master.bank”.

Can you share the full output log from Unreal when it fails to find the banks?

Outputlog errors
Yes! Here is the output log. We put the FMOD folder into (ProjectName)/Content/FMOD/Desktop and checked the Content Browser Prefix which is set to look at (ProjectName)/Content/FMOD/Desktop. We have tried a bunch of variations too and seems to be pointing at the right place, but not recognizing the Master.bank file.

Thanks for that, unfortunately it doesn’t help too much so I’ll give you a few other things to attempt:

  • In the FMOD Unreal Settings changing the Logging Level to Log, this will give us all of the logging from the FMOD API, then close the editor.

  • Manually delete all the folders in the ‘Content\FMOD’ directory (except for you banks).

  • Run Unreal or your UE project with an additional command line argument for additional logging from the integration.

  • Once open run the “Help > Validate FMOD” option in the Unreal Help menu.

  • If at this point it still does not work.

    • Close the project.
    • Reopen it (with the additional logging).
    • Copy all of the output log and paste it in here.