Upgrading from 1.10 to 2.01

Hey friends!

Upgrading our FMOD Unity integration here, and having an issue. Have cleaned out the FMOD folders, and the fmodstudiol.dll from the Plugins folders. Now only have the one error, (although, who knows, more may be hiding)

Assets\Plugins\FMOD\src\Editor\StudioGlobalParameterTriggerEditor.cs(21,9): error CS0246: The type or namespace name ‘EditorParamRef’ could not be found (are you missing a using directive or an assembly reference?)

I had assumed that the fmodstudio unitypackage would have installed this directive. Not sure which file normally has this EditorParamRef.

I did have the ERR_HEADER_MISMATCH before, but having removed the files and reimported the package, that seems to have gone away.

It sounds like you might be missing the file “\Assets\Plugins\FMOD\src\Editor\EditorParamRef.cs”, can you confirm that the file is in the project?

I am having the exact same problem when upgrading from 1.10 to 2.01.
I do not have the “\Assets\Plugins\FMOD\src\Editor\EditorParamRef.cs” file in my project. How do I get it back there?

I do however have it here: “Assets/Plugins/Editor/FMOD/EditorParamRef.cs”

Okay – I solved this by moving ALL the scripts from:

to the folder

And everything seems to work again, no errors so far :sweat_smile:

Ah yes, that can cause problems as the folder structure was changed in 2.00:

I will add a task to make this more visible for a future update.

1 Like

Wonderful, looks like this worked for me too. Thanks deHaan and Cameron!

1 Like

Got a really interesting update.

Seems some other members of the team pulled my branch, and are getting the version mismatch error, though it works for me. Should I get them to delete their local FMOD folders? It’s a pretty large team so walking each of them through integration is a bit of a non-starter.

That sounds like it would be the simplest solution.